Upgrade to 1.6.7 Failed...Need Assistance

Windows 10 - Have upgraded many times with no problem.

Updated today to verson1.6.7 and now get error “Child process exited with code 1”

Would appreciate, really appreciate, some help in resolving this problem a none of the encrypted files are available.

Same here :frowning: (
(edit) → I removed that version and returned to 1.6.5 (Win10Pro fully updated) and it launched, decrypted a test file and encrypted another.

I wouldn’t upgrade until this one is ironed out.

1 Like

Habe das gleiche Problem.

Danke für eine Hilfe!

Same here using, I downloaded the upgrade and reapplied while Cryptomator (1.6.5) was running, not sure if that’s supported or not but thanks @madmedix for the quick get out solution :slight_smile: that worked for me too.

Same here

Windows 10 - upgraded many times with no problem.

Update to version 1.6.7 and now get error “Child process exited with code 2

Beim öffnen über Programme und über Desktopverknüpfung. Öffnen über Info-Bereich erzeugt keine Meldung.

Hola, get exactly same problems. Uninstall all (cryptomator and dokany), re-install all without any success. Finally as recommended by cryptomator community, I have to install cryptomator 1.5.7 that loads dokany and upgrade cryptomator only at 1.6.4. I am using vault dokany. All is fine. Will wait later on to upgrade.

I got the same problem as discribed above!

There are some more reports to this on GitHub.

For the records and further investigation:
I had decided to install without third-party software, since WinSFP and dokany were already installed on my system.
No problems occurred.

I also ran into this problem. I’m running Windows 11. Initially, I tried upgrading using Cryptomator-1.6.7-x64.exe. That’s when I got the error. I uninstalled Cryptomator via Control Panel and then reinstalled using Cryptomator-1.6.7-x64.msi. Installation went smoothly and I am now running Cryptomator 1.6.7 using Dokan Library Bundle.
Hope this helps.

So it seems like this only affects users using the .exe installer, right? Please confirm

  • I used the .exe installer and got “Child process exited…” errors
  • I used the .msi installer and got “Child process exited…” errors

0 voters

Bekomme die Meldung in beiden Fällen (code 2).
Deinstallation, Reparatur etc. jeweils mit Neustart brachten keine Veränderung…
Meldung erscheint bei Öffnen über Desktop-Verknüpfung und aus dem Programm-Menü…über den Info-Bereich nicht.

Interesting. I just moved to a new computer and started getting these error messages. I don’t know what the Dokan Library is, but I understand it is used by CryptoMator in some way, so I downloaded the library, installed it, rebooted it, and the new version works fine now with no error messages.

After reading the threads below my initial post, I downloaded the .MSI version (Cryptomator-1.6.7-x64.msi ) and carried out an in place install, with Cryptomator running without any uninstall beforehand. Running the .MSI warned it was already installed and asked to close the program but then worked first time, so in my experience its only the .EXE that has this issue.

We found the cause for the broken installations. It is not Cryptomator itself, but only the installer. The workaround is to ensure, that during installation Cryptomator is not runnning.

If the app is running, the msi installers offers a reboot option and the exe installer requires it (due to files in use). But the reboot-and-install-mechanism is broken, leading to a broken installation afterwards. We are working on a fix currently.

1 Like

The bug is fixed and the fix is shipped with the newly released 1.6.8 version of Cryptomator.

For more information see the linked issue in Upgrade to 1.6.7 Failed...Need Assistance - #8 by Michael