Update Failed, App doesn't work, Data Trapped: NOW What?

App was working fine but after installing new version, app no longer works at all. In Windows Task Manager, cryptomator.exe shows as a running app but there is nothing displayed, no way to log-in.

So far I’ve rebooted, then re-installed, then re-installed after unchecking WebDav (Dokani was greyed out, marked already installed)

Now what???


From which to what version did you updated? Do you see a tray icon ?

To see if Cryptomator throws any error, please look into the log files and check if there are any ERRORs or WARNings.

Hello and thanks for helping.

  1. The log file (se below) says new version (for which upgrade failed) is 1.5.4
  2. Yes, there is a tray icon but nothing works when clicking (eg preferences)
  3. There seems to be a port error but all else seems normal.

Summary: app loads but no GUI presented and tray icon doesn’t work. Now what?

13:01:29.632 [main] INFO org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.5.4 on Windows 10 10.0 (amd64)
13:01:29.642 [main] DEBUG org.cryptomator.logging.DebugMode - Debug mode enabled
13:01:29.642 [main] DEBUG org.cryptomator.launcher.IpcFactory - [Client] Reading IPC port from C:\Users\marcus\AppData\Roaming\Cryptomator\ipcPort.bin
13:01:29.642 [main] DEBUG org.cryptomator.launcher.IpcFactory - [Client] Connecting to port 58359…
13:01:31.772 [main] DEBUG org.cryptomator.launcher.IpcFactory - [Client] Failed to connect.
13:01:31.797 [main] DEBUG org.cryptomator.launcher.IpcFactory - [Server] Wrote IPC port 58422 to C:\Users\marcus\AppData\Roaming\Cryptomator\ipcPort.bin
13:01:31.822 [main] DEBUG o.c.launcher.IpcProtocolImpl - Received launch args:
13:01:31.822 [main] DEBUG org.cryptomator.launcher.Cryptomator - Did not find running application instance. Launching GUI…
13:01:31.949 [main] DEBUG o.c.ui.traymenu.TrayIconController - initialized tray icon
13:01:31.962 [main] DEBUG org.cryptomator.common.CommonsModule - Starting App Background Thread 001
13:01:31.962 [App Background Thread 001] DEBUG o.c.ui.launcher.FxApplicationStarter - Starting JavaFX runtime…
13:01:31.967 [main] DEBUG org.cryptomator.common.CommonsModule - Starting App Background Thread 002
13:01:32.374 [JavaFX Application Thread] INFO o.c.ui.launcher.FxApplicationStarter - JavaFX Runtime started.
13:01:32.388 [JavaFX Application Thread] INFO org.cryptomator.jni.FunctionsLoader - loaded WinFunctions.dll
13:01:32.569 [JavaFX Application Thread] TRACE o.cryptomator.ui.fxapp.FxApplication - FxApplication.start()

UPDATE. TLDR: Re-installed but still doesn’t work!??

Since my data is trapped until app is working, I tried the following… from Windows settings, uninstalled app (all versions). Re-downloaded app: Dokani was greyed-out (‘already installed’), WebDav not installed (1 year ago resolved previous problem with Dokani; plus when previously installed a few days ago with WebDav, it didn’t work anyways.) Re-installed app. Invoked app: result as before. No GUI, but app visible in system tray, but right-clicking ‘show’ & ‘preferences’ does nothing. New log file below.

18:08:23.243 [main] INFO org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.5.4 on Windows 10 10.0 (amd64)
18:08:23.805 [JavaFX Application Thread] INFO o.c.ui.launcher.FxApplicationStarter - JavaFX Runtime started.
18:08:23.815 [JavaFX Application Thread] INFO org.cryptomator.jni.FunctionsLoader - loaded WinFunctions.dll

We had some reports that the GUI does not work when using the latest version of our graphics framework. One workaround is described here: https://github.com/cryptomator/cryptomator/issues/1049#issuecomment-575110614 (note that the section you need to edit is now called JavaOptions)

If you are able to interact with the tray menu, can you unlock your vault from there?

And finally, to at least acces your data, we also have a command line tool:

If your vault is already migrated (with 1.5.0 we introduced a new vault format), you need to wait a little longer, since the current release cannot open these vaults. But we’ll release an update to the cli very soon!

UPDATE: I finally got an error message, only by trying to run app from Taskbar. From a Windows window for cryptomator.exe, it says “No main class specified”. Then “Failed to launch JVM”

Hello. I looked at the GUI workaround & it did not appear to be about a total non-function of the GUI (but rather about something else) plus it was quite complicated… I’m an end-user, not a programmer. I also looked at the command line tool but I have the current vault format, since I was using version 1.5.x, so it wouldn’t work.

Therefore, I decided to simply revert to the previous version I was using that was working. Since I didn’t remember exactly which version that was but I knew it was recent, I downloaded and installed Cryptomator 1.5.3, which I believe was my working version. No Gui. So Uninstalled. Tried 1.5.2. No Gui. Uninstalled. Tried 1.5.1. No Gui. Uninstalled. Tried 1.5.0 No Gui. Uninstalled. Since v 1.4.15 was released in Aug 2019 and my working version was newer than that, I stopped at 1.5.0.

Every time I uninstalled a version, the message “some elements could not be removed. these can be removed manually” was shown. I figured that was harmless logfiles, etc. But then I thought there could be configuration files of some sort, so I tried once more, by reinstalling v 1.5.3 to the folder Cryptomator2. Still no GUI.

At this point, I’m totally out of ideas and totally frustrated. If I cannot get this working, I will need to find a competitor app that does work. To recap, in every single instance, the app loads into the system tray but the only command that works is Quit (‘show’ and ‘preferences’ do nothing).

Thanks. -MH

You edit a file… but it’s your call.

As far as I know, there should no elements be left in the installation directory, i.e. the directory Cryptomator is completely removed. You can remove additionally the settings directory under %appdata%/Cryptomator.

If you are sure, that previously an 1.5.x version was installed, then I guess something went wrong during installation. You can check this by running a standalone application, but it needs some steps:

  1. Install JDK14
  2. Rename the settings directory (e.g. into Cryptomator2)
  3. Download and unzip buildkit-win.zip from our releases
  4. Ensure, that there is no process cryptomator.exe running
  5. Execute the file launcher-win.bat in the unzipped directory

A terminal window pops up, showing the log output. Also, the Cryptomator application should start.

I can understand your frustration completely. Unfortunately, there will be always cases which cannot be solved. :slightly_frowning_face:

When I click the link

it points directly to the related comment:

Maybe related to JDK-8186981 for which the workaround is to enable software rendering by adding -Dprism.order=sw to the [JVMOptions] in C:\Program Files\Cryptomator\app\Cryptomator.cfg .

How do I modify the Cryptomator.cfg file in Windows 10 when the Security group “Application Packages” prevents me from using Notepad to add the suggested line?

Plus, I still don’t see the connection between my reported error and the error described in the link: “Always when I dock-out my notebook - which means moving from a three screen desktop to only naked notebook - all my applications under Windows 10 work as expected. The only one, which constantly has an empty screen is the Cryptomator app. It seems, as if the “on-paint” function is never called again for the elements of the form.”

An empty screen in a specific ‘out-dock’ situation seems to be different from my reported error: no cryptomator GUI screen whatsoever in ANY situation. I’m not a programmer but purely based on logic, the fix to a highly-specialized error seems unlikely to apply to a global non-function error. But anyways, I’ll try anything.

Sorry but this is really out of scope. If someone restricted your rights on your system, we can’t help you getting them back. This is something your admin needs to do.

The fix doesn’t say “paint the UI, even when docking out”, but rather instructs the UI toolkit to use a software-based renderer. Since there is no apparent reason for blank windows, it isn’t farfetched to look for issues that are specific to your system setup and therefore eliminate as many factors of influence as possible.

Re: “How do I modify the Cryptomator.cfg file in Windows 10”
Re: Permission settings ‘out of scope’

I agree it’s ‘out of scope’ but this is my PC at home, there is no ‘Administrator’ other than me. As an end user, I have not had occasion to modify the config files in any applications and clearly Win10 has more security settings than the original Windows 3.1 I used in 1988! (Probably before U were born. :)) If you guys are programmers, “Permissions” is basic stuff: it should be easy for y’all to give me a hint what to do. So, can I have a hint please? Pretty please? :slight_smile: Thanks in advance.

ps: I’d still like to know why uninstalling and then reinstalling the previous version (that was working fine until I ‘upgraded’) didn’t work.

Actually, if even if you are an “Administrator account”, there exists always the system admin account on Windows (its just hidden).

But to check if you are an administrator, got to the settings and click on the “Accounts” tile. There it is listed if you are a mere user or admin. If you’re the latter, enter “Notepad” in the Windows 10 search bar, right click on the app and select “Run as administrator”. Then you should be able to open the cfg file from within notepad and edit it.

If you are only a normal user, you need apparently any admin account. Maybe this helps:

One month later, after fruitlessly following all the technical advice given below, I got it working on my own. This is my response to other user with same ‘No GUI’ issue.


Hello. As a courtesy, I thought I’d mention what I did to get my cryptomator working when I had the same “no Gui, tray icon does nothing” error. First, after all the previous roll-back installations all failed (just like they did with you), I re-installed the latest version 1.5.3 (exe-166) to a completely new folder Cryptomator2. (I forgot to uninstall the older version.) It still didn’t work UNTIL i DID THIS: i just went to C:\program files\cryptomator2 and i invoked the cryptomator.exe file directly. THAT’S IT! That was all it took to get a working GUI. I’m not a programmer so I don’t know what was the difference from running it directly and using the Windows 10 Start Menu.

Other Notes:

  • I completely backed-up the database folder before upgrading it.
  • Left clicking on tray icon still does nothing, but right clicking works
  • To get Start Menu working, I deleted the old icon and clicked “add to start menu” for the new EXE file. Simple.

Good luck.