Unable to read or write files in vault on network share

Hello everyone,

first of all, in general cryptomator is running fine. I can create and unlock vaults and sync them via dropbox on several machines without any problems. However, when I copy one of the vaults onto my NAS, I can still unlock the vault and see all the filenames, but on a linux computer I get an error messages once I try to read a file or create/copy a new one into to vault.

If I do the same on a Windows computer, everything works fine and cryptomator opens the vault directly from the network share, files can be read and edited. If I copy the vault back from the NAS to the linux computer, everything works normal, as well.

I also tested this with the current beta version on linux and get an error message, too, although a different one. There is no difference whether I create the vault on the local hard drive and copy it on the network share or create it on the NAS directly.

I’m using cryptomator 1.3.2 on Ubuntu 16.04 and cryptomator 1.3.4 on Windows 7 respectively. The network share is a Netgear ReadyNAS and is mounted via SMB. While reading a file I get the error message “Failed to open input stream for file” (see picture 1), If I try to copy a new file into the vault the error message reads “HTTP Error: Server error” (see picture 2).

Picture 1 (Error message when trying to open a file inside the vault on the network share)

Picture 2 (Error message when trying to copy a new file into the vault on the network share)

Any help or hints where to get more information on this error would be appreciated.

Cheers, Stefan


I have the same issue with an Synology NAS

Unfortunately, I have not been able to resolve this issue, yet. I’m using this scenario to backup a cloud folder: Different notebooks sync the vault via Dropbox and the NAS automatically downloads a copy of the vault. Of course, it is still possible to just copy the complete vault onto one of the notebooks and open it locally. However, I do not see why it should not work to open a vault on a network share from a linux notebook. Works fine with Windows. Do you have any more information?

Same issue here.

Vault on Windows share:

  • Windows workstation can read/write to vault
  • Linux (mint) workstation can unlock vault but gets “HTTP error”

Same issue here.

Vault on Windows share:

Windows workstation can read/write to vault
Linux (Ubuntu 16.04 LTS) workstation can unlock vault but gets “HTTP error: Internal Server Error”

I have the same problem on ArchLinux. Files are on a Synology NAS shared folder. I tried both AFP and SMB for sharing the network folder. I tried 1.3.5 (with DAV) and 1.4.0-beta2 (with FUSE).

Files and directories are being created, but no data is copied. Files that already exist in the vault cannot be read, but can be deleted.

On Windows 10 everything works (using SMB).

I filed a bug report here: https://github.com/cryptomator/cryptomator/issues/696

1 Like

Same here. Ubuntu 18.04 LTS, with 1.3.2, 64 bit. Exact same error, verbatim, as Jochen.

Lest you think Linux users moochers, I’ve bought both the iOS and the Android apps, and look forward to being able to use them, ha!

Well, that pretty much settles it. So long so much silence? Cryptomator isn’t for Linux.

I’m not on Linux, but 2 People posted a workaround in the github issue. Maybe this will help you as well.

Absolutely not. While it appears to mount, it is no less inoperable, mounting as indicated. I have to sudo umount -f to get it to exit. Crypomator has beyond a doubt utterly failed Linux users.

i just wanted to know: Has this been fixed yet? The Bugtracker says its still untouched.

'cause i’m running 1.3.2 on ubuntu due to a 32bit system -with the exact same problem- however, i would upgrade to a 64bit computer just for this, if i will be able to use network shares properly.

Thanks in advance!

Seems like no one cares at all about this matter?

I’ve recently updated to a 64bit system just to check if the problem still exist in 1.4.15.

It does.

Using a network share with the linux version of Cryptomator is downright impossible. Opening / creating files ends with input/output or HTTP errors. Meanwhile the windows version works like a charm.

Well, that pretty much settles it. So long so much silence? Cryptomator isn’t for Linux.

Sadly, this man was right.

It is quite a strech to go from “not appropiate for a specific system setup” to “not appropiate for a whole class of operating systems”.

Yes, it may be working on windows, but we never actively “fixed” it there. It just worked. From this perspective one could rant now about different linux distributions and why such a thing is not supported out of the box, but this would also not fix the problem.

We love linux systems and also develop for them, but we need to focus our development and cannot always invest a lot of time for every specific system setup.

It is not that “specific system setup”. The simplest and most common way to access, say, Google Drive on a Linux, is to mount it via Gnome. While Cryptomator is supposed to be used for cloud encryption, the fact that it’s not possible to mount a vault on cloud on Linux, makes its use very limited. I am not sure fixing it should be on your side, or Linux, but it is disappointing for us, the users. Anyways, I like Cryptomator very much and I know you’ve done a decent job. I hope this issue to be fixed in near future.

It’s been 1.5 years once again and cryptomator is still not working on a network share (I’m on Windows).

I was planning to use Cryptomator with Icedrive for encrypted backups, but now that seems to be randomly impossible. What is going on here?!

You may not have noticed that this is a linux thread.
Please read this windows related thread and if this does not help leave an error description or even better a log file.