[SOLVED] Vault seems to be ok, but there is one folder (in a mounted vault) empty (6,5GB data missing)

I use cryptomator for a few months now and i am very satisfied.
Never had any issues but today after i configured my new notebook, i could install all the vaults but there is one folder in one of the vaults that is empty and there should be data of 6,5 GB data.
All the other vaults and the other folders in this “corrupt vault” seems to be ok (did not compared every file).

I made the inegrity-check:

Check Directory Check
CRITICAL - Directory ID reused: b2c22781-5506-4a5a-8871-fb3f3c47d348 found in C:\Users\norrin\OneDrive\PRIVAT\d\LO\CHVFJXNMRQXRGSOIXDRRKD2BOF3LAW\2vryojlUWk0vHLEV8nG4eCp8jDCndwFsDmvy8AspDqw9.c9r\dir.c9r and C:\Users\norrin\OneDrive\PRIVAT\d\4E\237OSQMIQATIDC6PGZFNBFFIU6KJFQ\XwwXM7F-ga1fa-9_fIFrsGGdUWpDmAfKYMwWv3fN03Oz.c9r\dir.c9r
CRITICAL - Directory ID reused: 5019a71c-d189-4a3c-a13e-4d1783810e07 found in C:\Users\norrin\OneDrive\PRIVAT\d\ZQ\F7VMF3SH35EZROLBLZYRN4VLT762KB\j0nuXKO_oUFydQF-hY1O7-W0pw==.c9r\dir.c9r and C:\Users\norrin\OneDrive\PRIVAT\d\U7\YYOB6EF3YBKZTHQHMN45RCK7TFN2QN\FftxIqvglSnLQUAGh0kjbtuD4g==.c9r\dir.c9r
CRITICAL - Directory ID reused: 91d36e8d-4d02-46b0-901e-37cef699d0bb found in C:\Users\norrin\OneDrive\PRIVAT\d\ZQ\F7VMF3SH35EZROLBLZYRN4VLT762KB\P8vq69BRB1ihxHbT1tjSj3J1.c9r\dir.c9r and C:\Users\norrin\OneDrive\PRIVAT\d\HR\SX46GUHUXFYP433GGDJ4MW4BXWDFRH\DdskTDI0QnZOMX_Zp0BDlQzw.c9r\dir.c9r
    GOOD - Good directory null () -> 3Q\B3ZGMCLIA2LUWA6Y4CRLFJ7CVIVALC

Is there a way to repair the vault?
Did delete and add it again but no difference.
Can this be a sync-problem?

OS: Windows 11
Software: Cryptomator 1.6.5
Me: Supporter

Which volume type do you use, and does switching it solve this problem? (Just to make sure this isn’t just another WebDAV issue)

The health check can be a result of sync problems as well.

Hi Michael,
the data is on Onedrive and youu are right, WebDAV is used.
How can i switch it?
There is no other option in the dropdown-field.

I mad a complete reset of onedrive using
%localappdata%\Microsoft\OneDrive\onedrive.exe /reset
This did not changed anything.

Installing WinFSP and switching to FUSE solved this issue!
Thanks Michael!