Mounted Drives hidden from sync program


I am unable to access mounted drives from a sync program (FreeFileSync) ONLY when FreeFileSync is run as administrator. Drives can be selected from and used for syncing only when FreeFreeSync is NOT run as administrator. I am looking into whether this is an issue only of FreeFileSync, but are there any known aspects of Cryptomator that could potentially be contributing to the issue?

Thank you

Hi. If you use dokany as file system, please make sure you use the latest version.

I remember there was an issue with dokany but it should be fixed with latest version.

Thanks for the suggestion Michael. I updated Dokan but FreeFileSync in administrator mode still cannot see the mounted Cryptomator drives. Same issue using WebDAV.

Wich user do you use to start Cryptomator? I guess it’s not the admin?
I assume that you are running the latest Cryptomator version?

To me your issue sounds like a user permission thing but I don’t know weather it is Cryptomator, windows or freefilesync.

Do you have other software that you can use to access the vault with a different user that the one you used starting Cryptomator? If yes, does it work?

Hi Michael,

I tried starting Cryptomator as administrator. After unlocking the vaults, the mounted drives do not show up in File Explorer, and selecting ‘reveal drive’ gives an error message that the drive is not accessible.

If I run Cryptomator NOT as administrator (so that the drives DO show up in Windows File Explorer), I noticed that the music player foobar2000 and also the torrent software Deluge both have the same issue as FreeFileSync. They are all ABLE to see the Cryptomator drives when NOT run as administrator, but are UNABLE to see them when they ARE running as administrator.

Im afraid I actually don’t have an idea right now what the cause of that behaviour might be.
Anyone else an idea?

See here: Cryptomator on Windows: Accessing your vault with admin priviliges

Thanks for this. Could you please explain what a CURRENT_SESSION flag is and how it can be removed?

I updated the linked thread to include a short instruction how to remove it.

The CURRENT_SESSION flag indicates Dokany, that only your user account (and every process started with it) can access the specfic unlocked vault.

Maybe add this explanation also to the OP of the linked thread? When reading the thread it was not clear to me, what the CURRENT_SESSION flag exactly stands for.

After reading the quoted sentence it’s clear to me now.