Lock Fail error

When I change an excel file, save it and try to lock the vault, I get an error. I tried waiting for a long while, but that did not solve it. Any suggestions? Here is an image:


No, I haven’t done that but I’ll try. The only time it happens, when I change a file, save it, close it and then try to lock the vault.

Which cryptomator version are you using and which type of drive in your settings?

Also sounds similar to my report here:

and also to the original report of @Joe210 here:

I have seen this happen with .exe files (always), and also occasionally with .dll files. I have not tested it with excel files as I am copying them out of the vault before editing due to a different issue with a much older version of cryptomator (years ago, but out of habit and caution I still prefer to do this).

Please provide version and drive info. If you have file backups (you should always have these), then you could try updating to the latest version of cryptomator, or preferably just test the latest version on another computer to see if the issue persists.

I’m using the latest version and this was occurring in my previous version as well.
I’ve been using Boxcryptor for years and loved it. Unfortunately, they’re shutting down. Cryptomator, sounds and looks like it is great alternative. The only thing is, that all of these errors scare me because all of my life is on those files… and I need a reliable, zero knowledge solution.

Off topic, but please be aware that the only way to avoid data loss is a solid backup strategy. No matter which storage or encryption solution is used. When I hear someone is scared of data loss, this means to me no backup strategy is in place and I cant stress enough out how important this is.

1 Like

I agree with you regarding backup. For now, I do have two versions of my files (Boxcryptor and Cryptomator) while I’m testing Cryptomator. All of my data is on GoogleDrive encrypted and I do not want to have anything permanent on my PC. What would you suggest for an easy, integrated, encrypted backup solution?

By the way, just tried the same with a LibreOffice text (.odt) document and same thing happened. Task manager didn’t indicate that Cryptomator is in use. After about 5 min, I was able to lock the vault. This only happens after I modify the file. I also use a VPN… can a VPN possibly cause interference…

A 3-2-1 backup strategy is my suggestion. And I prefer to have at least one (local) unencrypted. There are lots of backup solutions out there. I use this.

1 Like

Thank you, I’ll review the article.

Any further suggestions regarding “lock fail” error?

I see this occasionally (and randomly) and I have never been able to figure out why.

I’ve always assumed it’s a similar situation with a USB flash drive that Windows won’t allow you to eject despite not having any files open from it. There’s some Windows system process that has a lock on a hidden system file in the drive and the only way to get around it is to just restart Windows.

That’s my experience and assumption. Might be 1000% wrong. :smile:

Thank you. I guess Cryptomator not ready for prime time, very close, but not yet. I’ll be watching and keeping my fingers crossed, because it can be truly great but it needs to be reliable…

I don’t think you’re wrong. I’m having the same issue of not being able to lock a vault. It doesn’t happen all the time and not always with the same one. I’m using Win-11. Everything is current including Cryptomater version. I use onedrive. When I get the error message, I verify onedrive is no longer active, nor is task manager reporting back activity associated with Cryptomater that I can see. This app has a lot of potential, and I agree that backups are an absolute must, but the “lock fail” issue must be resolved to increase reliability or at least the perception of reliability. From the posts, it appears this has been a chronic issue for years. Hopefully, it can be resolved because I appreciate how the app works, its ease of use, etc. and want to keep using it.

For @infeo and @Michael, I recently had this happen. While it was happening, I ran ProcMon and attempted to lock the vault. I filtered the output to solely cryptomator.exe and saved it as a CSV file.

Not sure if it would be of any use to you or not. If you’d like to see it, please let me know along with where I should upload it to.