Cryptomator won't accept Google docs

I can store regular files in Cryptomator but not Google Docs. I do understand that the gDoc file is a link to the Google database and the file itself won’t be encrypted.

I get the following error: Invalid MS-DOS function

I’m using Google File Stream to access the files in Windows 10 and dragging the gDoc to the Vault and the error shown above comes up in a dialog box.

Error Message:

What does it say when you click on “more details”?

There appears to be nothing more. I clicked on it and it appears to be grayed out. I read in other posts where people imply that google docs can be in a vault but I’ve not been able to succeed at it.

I know there’s a debug checkbox but I can’t find any documentation on it. What are my options to debug this?

I can’t imagine why it shouldn’t work. After all, it is also just a pile of bytes… Will have to test this as soon as I’m back on Windows. On macOS this works as expected using both, WebDAV and FUSE.

The debug checkbox merely increases the log verbosity.

@LloydG did you test this without filestream? Eg with a gdocs file you have local?

@Michael, I not clear on your question. First, is there really a way to move a file into a vault on a Google Drive without using Google Drive File Stream in a Windows environment? My current understanding is that it requires it. I’m aware of Cyberduck (which I haven’t tried yet) but we are trying to keep things as simple as possible for the average user. When you use the term “local” are you referring to a gDoc that is in the Google Drive and somehow get it into the vault from the Google Drive web interface?

This is not an error specific to Cryptomator, see

To answer your other questions:

Maybe, you should try as suggested in the above article Googles Backup & Sync. In contrast to Google File Stream it holds always a local copy of your files.

Local means that the gdoc file is stored on your harddrive outside of Google drive. So no. There is also no way to access your vault content from the web interface.