Corrupted video files

I have a few hundred video files of RingCentral meetings that I downloaded and removed from their server and encrypted using the Cryptomator Windows app, which I keep updated.

A few months ago, I began encountering corruption which would cause VLCPlayer to suddenly stop, as though it reached an end of file, at one or two locations in the playback. These are patches of up to a few minutes in length; ie. skipping over the corrupted video by manually moving the VLC play head down the timeline a few minutes would allow it to continue playing. I now have 8 such damaged files. Other files of similar recordings, even those made during this period, do not have this problem.

Have tried Dokany, WebDAV and FUSE. Have tried Windows file repair on encrypted and unencrypted vaults. I started checking the downloaded files before encrypting but I may have missed some corruption at that point, because both encrypted copies, even if separately encrypted by the Cryptomator Windows app and stored on different physical devices, seem to have the same problem. In other words, it may not be caused by Cryptomator or my system at all.

However, I’m unable to work on repairing the unencrypted files themselves using other tools because I cannot recover or access them. Have tried saving converting the files to AVI in VLC player, and the converted file is truncated at the problem point. Have tried opening the files in Wondershare Removit and REMO Video repair but they will not see the vaults at all. Have tried copying the files to another unencrypted folder using File Explorer but that fails. Have tried WinMerge and it errors that it cannot compare those two copies of damaged encrypted files with each other.

Any suggestions? I have to replace Boxcryptor now for another usage and Cryptomator is the most-mentioned candidate for that, but I’m not that confident in it.


Might be this: Cryptomator on Windows: Accessing your vault with admin priviliges
Try mounting the vault as directory instead of drive

Any error message? Please make sure not to use WebDAV. I assume those files are lager than 4 GB and WebDAV cannot handle large files

You can try to access your vault directly online and download the files in it.

Thanks so much, Michael!
That actually works to get Wondershare access to a corrupted file!
Unfortunately Wondershare fails to repair it, either basic or advanced.
But at least I might try some other things.

Good to know, but all the files are each under 1GB and am currently using FUSE.
File Explorer error message upon copy attempt

Actually this use is strictly local encryption on two devices, no cloud involved.