Cannot copy files to vault mounted on Dropbox

I am running the latest version of Cryptomator (1.4.0) and Dropbox (63.4.107) on Win 10 Pro (1803 w/ all avail updates).

In trying to copy a 396KB PDF file from my laptop to my vault, I get a “not enough memory” error message. This happens whether the vault is mounted as a Dokany or WebDAV resource. Exact error message is:


This is on top of an annoying issue where some files in my vault cannot be removed from the same system that created the file. I have to remove them from another system (PC or mobile device).

I never had these problems when I first started using Cryptomator. I wish I could remember what version that was. But, it seems like since this 1.4.0 release (and maybe the one prior), I have been having more and more problems.

Any help that can be provided would be appreciated. Otherwise, I may just give up on Cryptomator all together. If I do, would it be possible to get my app purchases (Android and iOS) refunded?

same as this German post, but unfortunately no community feedback so far. (Just want to link them)

I can’t read or speak German so I appreciate it.

Also, if it’s of any use to the folks who do support (if they read this), I would be happy to provide debug logs from Cryptomator when this problem happens if it would be useful.

Seems that there’s an issue with pdf files and network drives for specific windows Setups.
I can not reproduce it as my PDFs do not throw that exeption.
Here’s a related post from the adobe forum.

1 Like

Interesting problem in that link.

For me, though, the file had already been in my Cryptomator vault for some time. I only ran into this problem while I was trying to put all of the files in my vault into a new encrypted ZIP file located on my local SSD using the latest version of 7zip. It’s part of my monthly backup practice. 7zip complained it could not access that PDF file along with a couple other files.

I noticed the file property for the PDF file in question was flagged “read-only”. So, I copied the PDF to my local system, unchecked “read-only”, and tried to copy it back into my mounted vault. That’s when I ran into this “not enough memory” error.

Between this problem and the other one I’ve been having where it sometimes won’t let me delete files from Windows, I’m starting to lose confidence in Cryptomator as my multiplatform encrypted storage solution. I may have to give up and pay for Boxcryptor.

I experienced this as well, and this also seems to have its cause in the windows WebDAV client.

You can either switch to dockany, or delete the file directly in the online vault by using cyberduck (also linked in the tread above)

I experienced this as well, and this also seems to have its cause in the windows WebDAV client.

I’ve been having this problem with a Dokany mount. All of my problems have been with the vault mounted via dokany. Though I have seen the problems with WebDAV, too.

Fyi: There’s an issue on github with Dokany that causes read only files undeletable.

I think I had seen reference to that in another post that I came across. It would be nice if that addressed the issues I’m having. I wonder how soon we’ll see the problem discussed in that posting fixed?

I recently posted a guide how you can remove the “read-only” attribute from your files stored in the vault:

Hope this helps!

Nonetheless the error message of windows is kinda confusing… i wonder if this is windows or cryptomators fault…

This is most likely an issue with NTFS Alternate Datastreams. Some cloud providers (Tresorit, Dropbox), use Alternate Datastreams to store metadata (cloud file ids, etc) in the file.

These result in problems when files are copied to a Cryptomator vault. Two examples:

  1. Bogus out of memory errors (especially when copying PDF files)
  2. Warnings about being unable to copy the file’s properties.

The workaround is to delete the alternate datastreams from the source files. This can be done with the Streams program found here:

WARNING: Removing the alternate streams may cause issues with copies of the files stored on these cloud providers. I was not concerned and deleted the alternate streams, but YMMV. You have been warned.

For more information on alternate data streams, see this article:

1 Like