Cannot access Cryptomator mounted drive as real drive

Hi Folks,

On Windows 10 latest insider preview, Cryptomator mounts the encrypted vault as a network drive and correctly maps a drive letter to it (S: in my case). If I type S: in the address bar of explorer, then I can access the drive. But S: does not show up in several of my file dialogs, in particular for the indexing program Everything. I can only see it as a network drive (something like \cryptomator-vault@xxxxx\DavWWWRoot\ID, where xxxxx is the port and ID is a hash?) and when I click on it, I get a message of “Windows cannot access \cryptomator-vault…”. This same result happens when typing that network share address into the explorer address bar. Cryptomator is not configured in any special way and the vault resides on my system C: drive.

Any help is much appreciated.


1 Like

Hi Marc,

I’m not familiar with the tool Everything, so I had a look at the FAQ.
There you can read, that everything is able to scan mapped network drives, followed by an instruction

So far so good, I tested it on an Windows 10 with the portable version of “Everything”.
As I was asked at start of the program to run it as admin to include indexing of NTFS volumes (which are not included if you don’t run it as admin), I startet the application as admin. And was able to reproduce your described behavior. No Network Volumes are shown.
I made a new network drive within my personal network (homeserver to gaming PC) to check whether its a cryptomator mount related issue or not. Its not.
My network internal drive was also not listed in Everything.

And I guess here’s the reason:
If your read the above linked instructions to the end, the following is mentioned:
If network drives are not listed in Everything, please try running Everything as a standard user: (followed by an instruction how to do that).

Well, I did that and voila: both volumes (cryptomator and my internal one) are listed and can be added.
From my point of view you’ll have to make a decision: indexing NTFS volumes, or indexing network volumes. both at the same time seems not to be possible by Everything.

BTW and offtopic:
There’s a reason why Microsoft prevents its own index service from indexing network volumes by call from client side. Assume a network with 10000 PCs and one File-Server. There would be a massive traffic on the network just to handle the client side index file requests. So Microsoft Servers perform the indexing and just provide an index file for the clients. This avoids traffic in the network and waste of performance on client side. But this is a server side feature and therefor has to be provided by the server system.

Hope this will help.

1 Like

Thanks for the research Michael. I figured this out from the notes as well but just remembered that this question was out there.

In fact, for anyone having a hard time with this, the solution is usually to run the application with normal (non-elevated) user privileges if possible. I had the same problem with SyncBack Pro, which needed to run with admin privs to backup open/locked files. Once I ran it without those privs, I could access my cryptomator drive but I of course lost some of the other advantages. What I still don’t understand is why I can type the drive letter into explorer (which is running unelevated) and it resolves correctly but I cannot type the UNC path into explorer and get to the drive. This is the very same UNC path listed next to the drive letter.

You must see the drive, which is not a folder, under Settings, you can manually add this drive or folder, then the folder is scanned and you can search in it