Vault.cryptomator not the same like masterkey.cryptomator


I have got a new Smartphone, the Vault is in the Storage local. When I try to connect, this Message occur:

vault.cryptomator-Datei stimmt nicht mit der masterkey.cryptomator-Datei überein.

Yesterday my Datas have been mirrored from Dropbox to my internal storage.
I have read a conflict of the vault:
vault (conflict date-of-mirroring).cryptomator.

I have tried to find a solution in the community. Maybe the Error-Message ist not exactly the same as in german.

Thanks for help

Currently normally a vault.cryptomator and masterkey.cryptomator file are placed next to each other in the root of the vault folder.

The vault.cryptomator file is signed with the key which is stored encrypted in the masterkey.cryptomator file. The error message means, that the vault.cryptomator file was signed with another key than provided from the masterkey.cryptomator file.

One possible reason could be that you have multiple vaults and copied one of the masterkey- or vault.cryptomator files into another vault folder?

Where this conflict comes from is very difficult to say, as well as whether it could have something to do with the problem because on the one hand the file is only created during the creation of the vault, afterwards it is only read-accessed which in itself should not create a conflict and even if there were a conflict due to metadata (e.g. modification date has changed) both files would still have to have the correct content, which could be verified…do both vault*.cryptomator files have the same content?

If i would have backed up my datas, i can try to cange bogh files?

Wait a bit, i have copied 3 Vaults on the infernal storage of my New Smartphone. And all Vaults show the same Message.
But at Linux, Android and Win10 (I suppose) they work.

Lets first find the cause of this problem, then I can tell you if backups would have helped here.

With “I suppose” you mean that you can unlock them? If you transfer the vaults reporting these errors in the Android app from the phone’s local storage back to your desktop, can you still unlock them?

All datas are mirrored.

I like to be independent of a Network. So, my vault is (the older Smartphone), on the SD Card. Dropsync mirrored the datas to the Dropbox. The Dropbox is connected with Win10, Linux and, recently, the new Smartphone, the Fairphone4. Only the Fairphone4 show me the Error.

Thanks for further information.

But please still try what I wrote above: plug your Fairphone4 into your computer, transfer the vault folder, which fails to unlock, to your PC and try to unlock it there.

I would like to rule out the possibility that data in the vault- or masterkey-file was changed during synchronisation with the Fairphone4.

I tried to connect the App directly with the cloud and it worked.
Maybe the App is unable to connect with the vault in the internal storage.

Yes and I highly assume that the sync to your Fairphone didn’t work completely that is why I suggest to plug your Fairphone into your computer, transfer the vault folder, which fails to unlock, to your PC and try to unlock it there. Then we know for sure that it is a problem of Dropsync and has nothing to do with Cryptomator, until we verify that, I can only assume it.