Unlocking vault doesn't open an Explorer window

os:windows

#1

I’m completely new to Cryptomator and have installed it on my desktop and on my wife’s desktop. I created a vault in my Dropbox folder, which has created a virtual drive W:. According to the video, when I unlock this vault within the Cryptomator app, it should open an Explorer window but it doesn’t. So there’s nowhere for me to drag and drop the files that I want to encrypt. What am I doing wrongly?


#2

This is your vault. Place your files here.
There is a configuration option that enables/disabled the opening of the explorer after opening a vault.
Please check this option if it fits your needs.


#3

Thanks Michael,

I sorry if I’m being incredibly stupid but I still can’t make it work. So I uninstalled the programme on both my desktop and my wife’s desktop, deleted the folders it had created in Dropbox and removed the W: virtual drives.

Now I have found a copy of “Cryptomator User Manual.pdf” so I think I understand how it’s meant to work. But now, when I open Cryptomator and create a new vault, no virtual drive is created and, when I drop down and click “Reveal Drive”, nothing happens. I went to my wife’s desktop and, using the Cryptomator programme, I opened the “masterkey.cryptomator” file in her dropbox. I can unlock the vault with the password but, once again, no virtual drive is visible on her computer and “Reveal Drive” doesn’t work.

Thanks in advance

Graham


#4

Which network adapter do you use for your vault? If dockany, then please switch to WebDAV and try again.
(Some people here reported issues with dockany.)


#5

Thanks Michael,

That helps and everything now works properly. I’ve now got it working on both our smartphones and all our computers except my wife’s laptop where opening Cryptomator gets stuck on “update check”. I’ve uninstalled and re-installed but it still get’s stuck. I’ve tried x-ing out of the update check window but it doesn’t work. I can live with this but I’m just rather intrigued.

Thank you for all your help.

Kind regards

Graham


#6

Mhm. I’m not sure if you can abort the update check, and go into settings.
If you can, please enable the debug mode and restart cryptomator.
After the restart wait until you got suck again and close cryptomator. Then please provide the Logfile of the session. Maybe this helps to identify where and why the process is stuck.


#7

Hi Michael,

I can’t get past the update check and so I can’t change the settings. I have tried uninstalling the programme and the Dokan library and re-installing with Kaspersky and Defender off but I still get the update check. Since it works on all my other PCs, is there a file that I could copy from their C:\Program Files\Cryptomator folders that might persuade this particular installation that an update check is not necessary?

Kind regards

Graham
[EDIT Michael: Don’t post telephone numbers in public boards]


#8

Further to my last, I’ve tried copying all the files from a functioning computer’s C:\Program Files\Cryptomator folder and Dokan folder but it still sticks at the update check.

Kind regards

Graham
[EDIT Michael: Don’t post telephone numbers in public boards]


#9

Web -> If you upgrade to 1.40 and use dockany then systeem is EXTREEMLY slow and NOT working.
HUGE CPU utilisation !!!

I reverted back to version 1.34 with webdav and evererything is fine again . …


#10

Hi,

Where can I get v1.34?

Kind regards

Graham


#11

Select the version you need.

Lessons learned … I safe ALWAYS the current version before upgrading :slightly_smiling_face:

cheers,
Jan


#12

You can find all releases on the GitHub Release Page
But: I can not confirm that 1.4 is so slow that it is unusable. Im also on 1.4 and yes, also in my case the Dokany interface is a slower than the WebDAV, but far away from not working.
And you can switch between WebDAV and Dokany in V1.4. No need to roll back to 1.34 from my point of view.


#13

I’m sorry, I have been away and not able to follow this up. But now there is another problem with the Android version on our phones. If I try to change anything in the vault, I get an error message that says “java.io.IOException: Unable to save file”.

The message continues:

“On Android KitKat and higher, apps are prevented from writing to removable SD cards. If the file is located on a care, it will have to be moved to internal storage”.

I don’t know where the vault is stored on our phones and, even if I did, I can see no way of altering in the settings to move it onto the internal storage.

Kind regards

Graham


#14

Thanks Michael. I have replaced 1.4 with 1.3.4-x64 on my wife’s laptop and it works fine. Oddly, it doesn’t do an update check! So that’s OK but please see my problem with the Android version on our phones.

Kind regards

Graham


#15

You can not edit the files directly from the vault, as android prevents this. You have to download the file, edit it, and upload it into you vault again.