Unable to access one of my vaults due to an "unexpected error"

Hi,
I’m using Cryptomator for Desktop on Linux (Ubuntu 18.04).
I just encountered an issue today. When I’m trying to open one of my vaults, after typing the password, an error message appears, with the following code (see below), and my vault won’t open:

org.cryptomator.common.vaults.Volume$VolumeException: Did not find feasible mount point.
	at org.cryptomator.common.vaults.FuseVolume.chooseNonExistingTemporaryMountPoint(FuseVolume.java:96)
	at org.cryptomator.common.vaults.FuseVolume.prepareTemporaryMountPoint(FuseVolume.java:73)
	at org.cryptomator.common.vaults.FuseVolume.mount(FuseVolume.java:55)
	at org.cryptomator.common.vaults.Vault.unlock(Vault.java:129)
	at org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:103)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:80)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:43)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)

I don’t know what it means, and I don’t know how to solve it. Can anybody help me?

It may be helpful to know that:

  • this vault is located in a folder that is synchronized with a cloud service.
  • I have other vaults, that are also located in cloud folders (working with different cloud services than the first), and they work fine.
  • I’m not sure if I have been able to update the cryptomator app properly recently. Several times, I downloaded the latest AppImage when it was available, and deleted the former. But every time when I opened the latest AppImage, and looked in the settings, it still said I was using an older version. For instance, I’m currently using the 1.5.5.11 AppImage, but the settings say I’m using 1.5.5.

Thanks for your help!

I’m pretty sure if the application says you are using 1.5.5, then you use really this version (and no recent one). How do you start Cryptomator? If you are using the search bar of GNOME, it may be possible that it starts an old version of Cryptomator installed via apt.

Regarding the problem: This is solved in newer versions of Cryptomator, for an in depth description see https://github.com/cryptomator/cryptomator/issues/1061. The quick solution is to quit Cryptomator and delete any directory left in ~.local/share/Cryptomator/mnt/.

Hi, thank you for your reply, the issue is solved now!