[SOLVED] WARN MissingDirectory path / Unable to rename or delete a folder


i have a problem with my Cryptomator Container.
–> I´m unable to delete or rename a Folder in it.

The sanitizer reports:

1 problem(s) found.
WARN  MissingDirectory path: d\EX\QEHFP4CAWLFK5CZDGQ3VQVCCNDT26B dirfile: d\P4\QZPPLFOGVJURRZOGK2KAWQLMM3OI5A\0EIOXS44YCN26MGB3O64VVH76WCIA==== notADirectoryButExists: false

In the first run i had delete more that 1000 orphan Metadata files

Remove orphan metadata file m\W3\E3\W3E3LXCNSCUXIGGL3BJW6VKIGIKDEJMW.lng... [OK]
Remove orphan metadata file m\XQ\6O\XQ6OFRTABXWOSHAAJD3WXFE3RRO3DLIO.lng... [OK]
Remove orphan metadata file m\3G\SF\3GSFGGRDWWKHUP3LGTTZ2YYRZ4DKICQZ.lng... [OK]
Remove orphan metadata file m\HZ\MY\HZMYIQO5Z5IJAWJXVEPJH3PYBZN3RN4K.lng... [OK]
Remove orphan metadata file m\K5\CC\K5CCNXOVISBWS2XC4BBPXE65HIZZOB2N.lng... [OK]
Remove orphan metadata file m\3H\JU\3HJUYWBGUQMPRDILXC3UC74ZMOMOKTBT.lng... [OK]
Remove orphan metadata file m\CQ\BX\CQBXKJXVMPQLAFN5ZH634JFELGGX7DXE.lng... [OK]
Remove orphan metadata file m\TJ\UC\TJUC4I6DLDQJWA5YF3T3KUFU3R63DE7D.lng... [OK]
Remove orphan metadata file m\XU\GF\XUGFRW2MRXTDDA6LDTQLERCWWOIYOU7E.lng... [OK]
Remove orphan metadata file m\HB\RF\HBRFL7ZXFIB3YVAQ6RP2O3XJPQ7HUZGQ.lng... [OK]

But the Error with the “WARN MissingDirectory path” still exists.
I´m using Mountain Duck under Windows 10 1803. My Vault is in the OneDrive Cloud.
I´m running the latest Cryptomator, Mountain Duck, sanitizer Version.

Is there a way to fix this problem ? Do you need more logs or informations ?
Thanks for any help!

MissingDirectory can’t be fixed automatically.

In your case, a directory file exists at this location:


But the corresponding directory does not exist:


This could be the folder that you were trying to delete or rename.

  • If you’d like to delete the folder, delete the directory file d\P4\QZPPLFOGVJURRZOGK2KAWQLMM3OI5A\0EIOXS44YCN26MGB3O64VVH76WCIA==== manually.
  • If you’d like to rename the folder, you need to restore the missing directory d\EX\QEHFP4CAWLFK5CZDGQ3VQVCCNDT26B.
    • Either you can find the missing directory d\EX\QEHFP4CAWLFK5CZDGQ3VQVCCNDT26B. Maybe the directory has something like (1) at the end due to a sync conflict.
    • Or create an empty directory d\EX\QEHFP4CAWLFK5CZDGQ3VQVCCNDT26B manually.

Thank you, Tobi.
I deleted the file as you described and the corrupt folder is gone.

Problem solved.

1 Like