Sanitizer throws error when using passphrase file

Attempts to use this code line:

java -jar sanitizer-0.16.jar encryptPath -vault /media/mark/DATA_ARK/D-crypt/ -passphraseFile /home/mark/Cryptomator/passphrase.txt -cleartextListFile ./plain-text-paths.txt -outputPath ./temp.txt

Results in the error, below. It seems that it doesn’t like the passphrase.txt file which contains only a single line with about 60 standard (typewriter) characters. That is, no emoji or strange characters.


Cryptomator vault sanitizer v0.16

Exception in thread “main” java.lang.IndexOutOfBoundsException
at java.base/
at java.base/
at org.cryptomator.sanitizer.commands.EncryptPathCommand.passphraseFromFile(
at org.cryptomator.sanitizer.commands.EncryptPathCommand.passphrase(
at org.cryptomator.sanitizer.commands.EncryptPathCommand.parse(
at org.cryptomator.sanitizer.commands.Commands.(
at org.cryptomator.sanitizer.commands.Commands.parse(
at org.cryptomator.sanitizer.Sanitizer.main(

I realize in my example that I used single dashes “-” instead of double dashes for the options. However, when I run it with the double dashes, I get the same error message. When I run it by hand, typing in the password, I get this message:

Enter contents of missing file d/KP/A26BWUCX2T5PPS3G5ZBYGUBYEKUIWD/0EPOVRX2HRURFZTTESRAH63JOTY======:

I have no idea what this means. The vault mounts, and I can find the path to the saved file. So there is no missing file that I know of. I was hoping it would tell me what encrypted path matches the clear text file.

What version of cryptomator have you been using the vaults with?

If you are using the 1.5.x branch , Sanitizer has not been updated to support the new vault format and will not work correctly.

I’m always reluctant to upgrade immediately. I’m still on 1.4.5, according to “settings”.

I’m wondering if some of the options of sanitizer don’t get tested due to lack of interest. I really don’t understand why I’m being prompted to supply content when I just want to know the path to an existing vault file.