Sanitizer Found 2369 problem(s):

os:linux

#1

I got the feeling some files went missing. So I downloaded the sanitizer and ran it on one of the encrypted directories. This is the result.

Any reason why there are so many problems?

Everything works like it should. But again, looks like some missing files.

[kfo@kfo ~]$ java -jar /home/…/sanitizer-0.15.jar check -vault /home/…/Dokumenter_enc/

Cryptomator vault sanitizer v0.15

Output file(s) exist. Overwrite [Y|n]?
Vault password:
Scanning vault structure may take some time. Be patient…
Wrote structure to Dokumenter_enc.structure.txt.
61158 files in vault

Checking the vault may take some time. Be patient…

Found 2369 problem(s):

  • 0 FATAL
  • 2335 ERROR
  • 34 WARN
  • 7379 INFO

See Dokumenter_enc.check.txt for details.

Done.
[kfo@kfo ~]$


#2

Well… Your post has a rather big cliffhanger: :wink:

What are the problems?


#3

I’m not sure if files are disappearing. I will run them find command on the unencrypted files and run diff on the different find outputs.

Can I safely fix these problems problem that the sanitizer is showing?

Tried to to read the documentation, but not sure what the correct commands to run is.


#4

Just wanted to add this. Not sure if this is a problem.

#Find outputs files found in the unencrypted directory (mounted)
[kfo@kfo ~]$ find cryptomator/dokumenter/ -type f |wc -l
36547

#Find outputs files found in the encrypted directory (not mounted)
[kfo@kfo ~]$ find grive/Dokumenter_enc/d/ -type f |wc -l
43291
[kfo@kfo ~]$


#5

For the record: OP sent me the check log via PN.

You have a lot of files that are reported as empty by the underlying file system. Where is you vault located? Maybe some fancy non-standard filesystem?

The errors reported can not be fixed automatically. A lot of the ciphertext files are reported to be empty. Sanitizer can not guess what should be the correct contents.

It is expected that you have more ciphertext files than cleartext files. This is due to the fact that also directories and symlinks end up as files and for every file with a very long name there will be an additional file inside the m directory.


It is indeed possible some files are now missing. Neither is it possible to show files in the directory listing, for which the corresponding .lng file in the m dir is empty, nor are empty ciphertext files shown.

To solve this, you need to find out, why that many files are empty.


#6

The vault it stored on a ext4 filesystem.

[kfo@kfo ~]$ mount| grep home
/dev/mapper/fedora-home on /home type ext4 (rw,relatime,seclabel)

I can see that there are some old log files from 2005 that are 0 byte

[kfo@kfo dokumenter]$ find -size 0 | wc -l
1748
[kfo@kfo dokumenter]$

The problem for me is that there are over 60 000 documents/files from way back until today.
It’s hard to notice some files disappearing.

The reason I tried the sanitizer is a lot of warnings from cryptomator:

12:57:08.412 [Thread-86213] WARN o.c.cryptofs.CryptoDirectoryStream - /home/kfo/grive/Dokumenter_enc/d/DE/5MFL6WUIJFQPKBRGEAEU65CQVRE36Q/THV4VVDOQ6ACEY7IDTQG2RMQRLTGT2D4.lng could not be inflated.
12:57:08.465 [Thread-91613] WARN o.c.cryptofs.CryptoDirectoryStream - /home/kfo/grive/Dokumenter_enc/d/AF/DL3AJYYVYBH42O2KLTZV3JNM5BJ24S/DE33P45PMCXLW2NXL6FUXRJ5VFOTYAB4.lng could not be inflated.
12:57:08.465 [Thread-86213] WARN o.c.cryptofs.CryptoDirectoryStream - /home/kfo/grive/Dokumenter_enc/d/AF/DL3AJYYVYBH42O2KLTZV3JNM5BJ24S/DE33P45PMCXLW2NXL6FUXRJ5VFOTYAB4.lng could not be inflated.

But if these are just warnings, no problem.


#7

Yes, it is a problem. It doesn’t have any negative effect on your other files, therefore it is just a warning during directory listing. But as your sanitizer check result confirms, (not just) a lot of your .lng files are empty.

Search for DE33P45PMCXLW2NXL6FUXRJ5VFOTYAB4.lng inside your m directory. Can you confirm that this is a 0 byte file?


#8

The file is not zero byte.

And this file is not in the m directory. It’s in the d directory.

[kfo@kfo grive]$ find -name DE33P45PMCXLW2NXL6FUXRJ5VFOTYAB4.lng
./Dokumenter_enc/d/AF/DL3AJYYVYBH42O2KLTZV3JNM5BJ24S/DE33P45PMCXLW2NXL6FUXRJ5VFOTYAB4.lng

[kfo@kfo grive]$ find -name DE33P45PMCXLW2NXL6FUXRJ5VFOTYAB4.lng | xargs ls -lh
-rwxrwxrwx. 1 kfo kfo 375 mars 29 13:56 ./Dokumenter_enc/d/AF/DL3AJYYVYBH42O2KLTZV3JNM5BJ24S/DE33P45PMCXLW2NXL6FUXRJ5VFOTYAB4.lng

[kfo@kfo grive]$ find -name DE33P45PMCXLW2NXL6FUXRJ5VFOTYAB4.lng | wc
1 1 90


#9

Files ending on .lng always come in pairs: The file inside the d directory contains the actual file contents, the file inside the m directory contains the ciphertext file name.

If one of them is missing or empty, it leads to errors.