Same password doesn't work between linux and windows client

Hello,
I’ve got a first personnal computer on Xubuntu 18 and cryptomator.
At my work, I’ve got a second computer on Windows 10 x64 and cryptomator too.
Crytomator vault is synchronised by Owncloud between the two computers.
The same password used on computer 1 doesn’t work on computer 2.
Strange thing, the very first test I did was to create a fresh vault with a simple text file into it: the password (same as today) was working well.
Later, as soon as I put a lot more files (about 150 Mb), same password didn’t work anymore on computer 2.
Last year, my two computers were on Windows (my personnal one was on seven x64), and cryptomator worked as a charm.
Are Linux and Windows desktop app well compatible ?
Thanks a lot in advance for your help.

I just tried to open again my computer 2 vault. Here the corresponding log:

12:52:42.267 [main] INFO  org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.4.15 on Windows 10 10.0 (amd64)
12:52:42.527 [main] INFO  o.c.launcher.IpcProtocolImpl - Received launch args: 
12:52:42.840 [JavaFX Application Thread] INFO  org.cryptomator.launcher.Cryptomator - JavaFX application started.
12:52:43.030 [JavaFX Application Thread] INFO  org.cryptomator.jni.JniModule - loaded WinFunctions.dll
12:52:43.079 [JavaFX Application Thread] INFO  o.c.ui.controllers.MainController - Unable to setPreferencesHandler, probably not supported on this OS.
12:52:44.778 [JavaFX Application Thread] INFO  o.c.ui.controllers.WelcomeController - Current version: 1.4.15, lastest version: 1.4.15
12:52:46.212 [JavaFX Application Thread] INFO  o.c.k.WindowsProtectedKeychainAccess - Unable to load existing keychain file, creating new keychain.
12:53:04.251 [JavaFX Application Thread] INFO  org.cryptomator.launcher.Cryptomator - JavaFX application stopped.
12:53:04.262 [main] INFO  org.cryptomator.launcher.Cryptomator - Shutting down...
12:53:04.275 [Thread-0] INFO  o.c.launcher.CleanShutdownPerformer - Goodbye.

To 100%.

If the displayed message says incorrect password, then the character sequence is a different one.

I remember a case where the user used apostrophes in the password input, leading to a different characters because `s was translated to ś, see

Hello,
thanks for your reply.
I’m 100% sure about my password, I use it a lot for a long time now, so no error is possible…
Because it is only capital letter and digit. Neither special character, nor apostrophe.
The first thing I did was to create a fresh vault on computer 1 protected by a simple password “1234”, then put a simple text file in, open the vault on computer 2, verify the text file…
Then change the password on computer 1 with my usual password, verify on computer 2 that work properly…
Then put a lot a file on computer 1, and verify on computer 2 => password the didn’t work .
Maybe as explained in the post you mentionned a different keyboard set. However it’s strange, as it is a french keyboard on the two computer.
I will try with a simple password with only number again.

To find the cause for this problem, can you do the following?

  1. Ensure on both systems you have the newest Cryptomator version running
  2. Enter the not working password in cleartext in some editor and save it somewhere secure (e.g. another cryptomator vault)
  3. On Computer 1 (C1) create a new vault with the above password by copying it from the editor
  4. Copy the vault (the directory with masterkey.cryptomator) and the file containing the password to Computer 2 (C2) (via usb stick, uploaded zip-archive, etc)
  5. On C2 add this vault to Cryptomator
  6. Try to open it by typing the password
  7. Try to open the vault by copying the password from an editor
  8. Report back the results (including the Cryptomator versions running on both systems)

For real usage I advise against using a “simple” password so it just works.

Hi,
indeed it was really a bad password as you suggested me. I think there was a problem with capital letters, because the same password in lowercase works on both computer. So, it’s working for now, thanks a lot for your valuable help.
Pascal

© 2020 Skymatic GmbH • Privacy PolicyImpressum