Problem with more than 1 vault

I have a problem with multiple vaults. All waults I have from previously version.
After I installed new version 1.5, I have empty vaults.

I added one vault, and one vault works OK.

When I tried to add second from my vaults (all vaults are migrated to 1.5), I not working. Nothing happens (after I drag´n´drop “masterkey.cryptomator” file).

When I tried to add second vault by click to “add vault” (“Pridat trezor” in my lang), I go to “open exist vault”, I search “masterkey.cryptomator” file, and after I add it, nothing happends.

All my vaults are in Google Drive.


Another user also reported such a problem on our bug tracker:

For any updates, look there.

I must admit, this sounds a little disturbing because i have absolutely no idea what can be the cause for this. Maybe it is google drive related.

@ghost Are you als unable to create an additional, new vault in google drive?

yes, new vault is possible to create to empty Cryptomator.
When I tried create second new, It will be also created correct (on Google Drive), but not add to Cryptomator left menu.


The probably reason is, that Cryptomator try to add vault with previous name => first created vault has name “testnew” and second created has name “testnew2”. It can be seen in screen.

I look to LOG and see difference between adding first and second vault:
After add first vault is:

05:59:58.518 [App Background Thread 005] INFO  o.c.u.a.CreateNewVaultPasswordController - Created vault at H:\*PATH*\testnew
05:59:59.535 [App Scheduled Executor 01] DEBUG o.c.common.settings.SettingsProvider - Attempting to save settings to C:\Users\*SOMEUSER*\AppData\Roaming\Cryptomator\settings.json
05:59:59.536 [App Scheduled Executor 01] INFO  o.c.common.settings.SettingsProvider - Settings saved to C:\Users\*SOMEUSER*\AppData\Roaming\Cryptomator\settings.json

After add second vault is only:

06:02:14.351 [App Background Thread 005] INFO  o.c.u.a.CreateNewVaultPasswordController - Created vault at H:\*PATH*\testnew2

and missing save to settings

Can you add a second vault after restarting the application?

It is possible you found a bug where we didn’t correctly clear the state of running the “add vault” dialog twice.

I cant add second vault after restarting app.
I cant add second vault after reinstall app.

I just created 3 new Vaults in Google Drive with CVyrptomator v1.5.0 :slight_smile:

My issue is non working SMB3 mapped Drive

Do you use Google Drive File Stream, or common Google Drive?
Are you on Win10?

Win10Pro Build 1909 update 2020-04 and use common Google Drive.

Same problem here, Windows 10 Pro 1909 build 18363.778, Cryptomator 1.5.0, Dokany.
I’m using Drive File Stream and I can’t see more than one vault in Cryptomator, although it gets created.

Same problem here, Windows 10 Pro 1909 Tradition Chinese edition build 18363.778, Cryptomator 1.5.1, Dokany.
I’m using Google File Stream and I can’t add more than one vault or open second existing vault in the same drive.

But I can add second vault or open existing more than one vault in the same microsoft one drive.

Yet another issue reported on GitHub with multiple drives on Google File Stream.

We will focus our investigations on this scenario. Sorry for the inconvenience and thanks for staying patient! :slightly_smiling_face:

I can now use more than 1 vault :clap: :+1:


Yes, it should be fixed with Version 1.5.2 :slight_smile: