OneDrive issues on iOS app


#1

Whenever I try to open or create vaults stored in OneDrive I receive the error message: “vault” could not be found. (Vault is whatever the particular vault is named). I am signed in alright and can see all of the main folders I have in my OneDrive. I also tried to download the whole file for offline use with the same result. Am I missing something here or what is the problem?


#2

Just to make it clear: you can select a folder in your onedrive where you want to create the vault, and can create the vault? The error appears when you want to log into that vault again?


#3

When I’m trying to make a new vault I can name it and set a password, but when I try to actually finish the creation it shows the following:

I then have to navigate back and cancel the creation. However, when I go to add an existing drive the new vault I tried to create shows up as follows:

However, when I go into my OneDrive app there’s nothing more than an empty folder titled Vault (no M or D folder, etc.)

When I try to open my other vaults that have been opened in the iOS app previously (I estimate they were last opened on iOS 2-3 months ago and I keep things updated fairly well) the phone shows the following message:


#4

Hi. Thank you for the detailed description and the screenshots.
Im also using OneDrive and tried to reproduce the error. But in my case everything works perfect.
Do you have an entry for cryptomator in your iPhone analytics? Means, is there an error/crash record?
(Settings->privacy->analytics)

I noticed an app update today. Although I didn’t have any problems with the version yesterday, maybe the update helps?


#5

No there is not.

The update unfortunately did not help.

I don’t know if it’s relevant, but I am using an enterprise Microsoft account.

Whenever I try to add an existing vault the log in the app shows the following:
2019/01/15 19:50:45:062 Adding existing vault “(null)” ((null)) was successful

One possibility thing I noticed is that when adding an existing vault from iCloud, I can navigate folders and choose the masterkey file; however, in OneDrive I can only click on the main file folder. For example I click on Vault from the second picture above and it goes directly to the screen on the third picture.

Also when I tried to create a new vault it said this: 2019/01/15 12:09:49:516 Creating new vault failed: Error Domain=com.microsoft.graph.errors Code=404 “not found” UserInfo={error= UnknownError : 404 FILE NOT FOUND, NSLocalizedDescription=not found}


#6

Im also on an Enterprise Account.
There should be no different behavior between iCloud and OneDrive when creating a new, or adding an existing vault. In my case at least there’s no difference.

For me it looks like read/write via the configured OneDrive connection is not working for whatever reason.
Can you please log off the OneDrive connection in cryptomator settings, and then log in again?


#7

I have logged out and back in, but that did not fix it.

Are there maybe Microsoft app permissions or something that in my Microsoft settings preventing Cryptomator full access?


#8

You must grant cryptomator app access to OneDrive. But that permission is usually set with the first login.
You can check the permission in your microsoftonline.com account.


#9

On a whim I remembered that I had deleted a sharepoint site around the same time that I had begun having access problems with Cryptomator. I went into my settings and restored the site. I can now access the existing vaults and can create new ones.