Mounting more than one drive

Hello, I have only recently started using Cryptomator. I have setup a few vaults, all of them have the drive letter set to be assigned automatically. However I can only mount one vault at a time. When I try to open the 2nd vault, cryptomator will unlock it but will not mount the vault. Is this normal behaviour or is there some setting I can make so thatit mounts more than 1 vault. There is no error shown, the additional vaults just do not mount.

I have noticed that if you assign fixed drive letters then I can mount more than 1 vault, but I don’t want or need to assign fixed drive letters.

OS: Windows 10 Pro x64, latest public release build with updates.

Just did a super quick test and was unable to reproduce the issue. Are you sure that there are no errors? Could you please look inside the log file?

Thanks for your reply.
Well today I started my laptop and all worked correctly. I was able to mount multiple drives when no fixed drive letter has been reassigned. I can not explain why it worked correctly today as I did not change anything on the laptop, just started a new day.

However I was able to find 2 logs from previous days which show an mounting error “mount failed” and “Local device name already in use”. I assume it was because the device name was in use that it did not mount, but I can not explain why as I had no network drives in use, so I do not understand what it is referring too.

When using Cryptomator I open and close vaults as I need them, so maybe there was some leftover or something blocking it.

If you wish I can send you the log files with errors, just please explain how t send log files.

Thanks again for looking into this.

Just an update.
After using the Cryptomator today for a while, opening and closing vaults the above issue has come back.
I see now that I am getting the “Connecting drive failed” error, with a “System error 85 has occurred”; The local device name is already in use. So it appears that Ihave similar problem to the other thread here “Connecting drive failed” but with a different error code.

After just looking at Cryptomator behaviour it appears that Cryptomator want to open the 2nd vault with same drive letter as the already opened vault. This only happens with vaults where no assigned fixed drive letter.
So it appears to me that Cryptomator is not assiging drive letters correctly.

This is just an observation by just looking at what drive letters Cryptomator asigns by opening and closing various vaults. It seems to assign the last drive letter used.

Thank you for the error code! At least that’s a start but it’s still weird. :laughing: We’re using the net use command to mount the virtual drive (which is technically based on WebDAV). If there is no specific drive letter assigned, Cryptomator will execute net use *.

I can’t really find anything specific on net use * causing “system error 85”. And your report is actually the first one I’ve read so it may be a rare or at least somewhat specific issue (only occurring under certain conditions). If you have a reproducible scenario, please let me know and I’ll try it here.

This tells me to set /persistent:no but we’re already doing that (see code above). net use * /d (short for /delete) is quite a drastic approach. You could try it out, maybe it helps.

This tells me that there is a specific issue when you’re a non-administrative user. If that’s the case, Microsoft suggests to change something in the registry.

I’m not convinced that any of the articles are relevant because we’re executing net use * and not net use with a specific letter (if and only if the drive letter is set to “Assign automatically” in Cryptomator).

Thanks for your response. I think I can reproduce the issue so will try to describe below. The issue appears to only happen when I have previously opened a vault with a pre-assigned drive letter. After I do that then I can not open a 2nd vault and get the error 85 in the log file.

In my case I have 8 vaults, but I don’t think the quantity of vaults makes a difference.

  1. If I setup all my vault with non-assigned drive letters, I can open up all 8 vaults one after the other and Cryptomator will assign consecutive drive letters starting with Z:, So Vault 1 = Z:, Vault 2 = Y:, Vault 3 = X: etc. So no problem here.

  2. Now I assign 1 vault (it does not matter which vault) a pre-assigned drive letter, say drive letter T: I then open this vault with Letter T:, no problem here.

  3. I then try to open the another vault and it fails to mount. It will unlock but just not mount. Now I get the error “Connecting drive failed” and error 85 in the log file. So here I can not have more than 1 vault open at any time because each successive vault fails to mount.

  4. If I close the vault with letter T:, I can then open any other vault (with un-assigned drive letters), but it will mount with drive letter T: (as oppose to Z: as default). But now I can not open my vault with pre-assigned letter T:, because now T: is in use with another vault. I think this is a problem and should not happen. I think Cryptomator should not open non-assigned vaults with letters from pre-assigned vault. Something for you to consider.

  5. Also now I can not open any other vaults. All other vault fail to mount.

So from this point on, every vault which I open, opens with T: and I cannot open a 2nd vault.

To solve this, I have to shutdown Cryptomator and restart it. This seems to flush the memory of using T: and then all vaults can open as described in point 1 above and all is again well until I open a vault with pre-assigned drive letter.

I also run Mountain Duck to mount drives sometimes, not permanent, just off and on. I thought there maybe some conflict there but it appears not to be any conflict. Cryptomator avoids using drive letter already mounted by Mountain Duck. For example, if Mountain Duck mount a volume with drive letter Z: (which Cryptomator uses as first choice), then Cryptomator will avoid that letter and mount on letter Y:

Also I don’t or do anything special to my setup. It is essentially a standard windows 10 pro installation with default settings. I do not go tweaking things.

I hope you understand my description and that you (or somebody else) can reproduce it, as I would really like to get off the “rare issue” list.

Hey there! Sorry for the late response but I finally got around to test your scenario. And yes, it’s absolutely reproducible and a bug! Thank you for finding it. :+1:

I’ve written a bug report here: