Lost 10 years of data, would like some insights

Hi all,

So as the title says, I lost 10 years of data and of course I have only myself to blame. I’m always pretty strict with backing up all my data but unfortunately due to two assumptions / actions I lost all my data. This includes photo’s, video’s, documents the whole shebang. Might be able to get some things from a few old hd’s but 90% is lost. Of course I was quite upset the moment I found out, but worse things can happen in life, that I know.

Reason for my post is that I would like some opinions about, what I think is, the cause. First I’ll explain the backup solution I had, followed by the ‘cluster***’.

At a cloud hosting service I had 1000gb worth of space, mountable with Webdav. That worked great, it was fast and I could easily mount them. Then I made vaults with Cryptomator for several purposes, eg: media, documents etc. So I would mount the remote storage with webdav, and then open the specific Vault I wanted to access.

Of course several things went wrong. I wanted to get a clean install of OSX High Sierra on my Macbook, so I backupped all the files ONLY to the cloud storage provider using the method I just described. Of course this is my mistake, because as of this point I only had 1 replica of my data. So 1 point of failure.
Then I reinstalled OSX, everything went fine. Mounted the drive with webdav and right away mounted the vaults with Cryptomator. Then the folders were empty, I thought it just had to sync, but no. When I logged in to the cloud storage provider’s web interface, the vault’s directories were just a mere 60kb in size.

It turned out the service I used did not make backups on the plan I was on, another paid plan DOES make backups. Unfortunately they can’t get it back, and I don’t blame them.

I’m not sure about where things went wrong with Cryptomator. I have two possible causes:
#1 I should have waited a bit and not open the vaults right after mounting my webdav.
#2 I probably installed a newer version of Cryptomator, so that could be a possibility.

I really would appreciate some thoughts about how the vaults were purged. Because it’s quite a big deal, and at least I want to know exactly how this happened.

Thanks in advance!


From my point of view and experience with cryptomator, none of your 2 assumption should cause the deletion of encrypted files.
Cryptomator does only delete encrypted files, if files in the vault are deleted.
Even if there is a problem with connecting the vault, or if you try to mount a vault that is not compatible with the used cryptomator client, the encrypted files stay available in the online storage (or wherever they are located).

Based on your information I have the following ideas what might caused your experience.

  1. The upload of the encrypted files has not finished or did not happen for whatever reason.
  2. Some other process deleted the files online. Do you have access to a recycle bin?

I’m pretty impressed that you managed to enabled a direct WebDAV connection to your online storage and call it “fast”. I tried this with Onedrive and it was unusable slow because of the WebDAV client. So I switched to standard setup, which means the encrypted files are stored in my local folder that is synced by onedrive client.

Hi Michael,

Thanks for the explanation. I’m sure all files were uploaded correctly but got emptied when I mounted them. And unfortunately, there’s nothing in the recycle bin…

Yes the WebDav was fast enough for normal usage, did not notice any delays. I might go with the standard setup from now on as well. Should be more robust, less moving parts.