Item in Parenthesis on "Reveal Drive" Button

Searched for this, but I seemingly couldn’t find it covered in the Docs or here on the forum.

Today I noticed something different about the “Reveal Drive” button for one of my vaults. It had been open for some time (copying 75+ GB into it), and the “Reveal Drive” button showed (as usual) the location of the vault - e.g., /Volumes/asdfghj - but there was another item in parenthesis - e.g., (NDjhdketw) - appearing just to the right of the vault location, within the green “Reveal Drive” button. Hadn’t seen this on a vault before; locking and unlocking the vault caused it to reappear, albeit with different content inside the parenthesis. Everything appears to be functioning normally, though. Can anybody clue me in to what this item in parenthesis means? Unfortunately I didn’t manage to capture a screenshot.

I should note that this vault was on my Synology DS218+, and I was connecting from my Mac. It seems connecting to the vault using FUSE over an SMB connection to the DS works, although I gather this is not officially supported. However, this connection seems to be more stable than trying to use WebDAV - which I can do, but I run up against WebDAV limits with large data copy/move functions. Not sure if the connection type had something to do with the parenthetical item above, but I thought I’d mention it in case.


If you look inside the /Volumes/ directory, does the directory /Volumes/asdfghj/ still exist even though it’s not mounted/unlocked anymore? Maybe the unmount/lock didn’t work properly and didn’t clean up, which is now “blocking” subsequent mounts/unlocks.

Well, I do feel a bit sheepish … the answer was rather simple. Overlooked that I had set up the same vault over both SMB and WebDAV … and when you open it with two separate connections simultaneously, the second connection (whichever of the two it may be) gets assigned this parenthetical label (see image above). It also appears in the “Get Info” window for that vault when you look for it in /Volumes in Finder; I inlaid the relevant portion of that window at the bottom of the image (still a new user, can’t post multiple photos).

That label appears to be unique to that particular instance of adding a vault into Cryptomator: if you unlock and lock the the vault (via the two connections), you should see the same parenthetical labels appear for each of those instances across multiple lockings/unlockings, regardless of the order in which you unlock them. The one opened second always gets the parenthetical label. And that label remains visible until it is locked again, even if the first one is locked before the second. But, if you remove the vaults from Cryptomator and readd them, these labels change.

Also tried this with two WebDAV connections to the same vault (via a local URL and FQDN), and the behavior was the same - so it doesn’t appear to be specific to particular connection type. Curious if this behavior is specific to Cryptomator, or if it is a FUSE thing … in any case, there it is.

It is the behaviour of Cryptomator and it intended.

To easily identify the access point to the unlocked vault in the filesystem, the point has the same name as the vault. If you have two Vaults with the same name, those cannot be mapped to the same access point in the filesystem.
So when you unlock the first, it takes the free access point and hence, the second vault needs to use some suffix such that it can also be mounted/accessed. As the suffix, the app internal vault id is used as the suffix.