Getting right version of Java to run for sanitizer

os:windows

#1

Maybe more of an issue with my Java installation than with Cryptomator but hoping someone can help…

My Windows 10 PC crashed while some files I had added into a vault were being synced through Drive File Stream, and now I am having some issues with the vault; some text files now freeze some text editors and make File Stream use a lot of CPU, deleting these problem files in the vault and trying to copy it into the vault again throws up an error claiming that the source file doesn’t exist when it does and files being copied in for the first time still do so successfully.

Therefore I want to run the sanitizer, but even though I have Java 9 installed and I set JAVA_HOME to C:\Program Files\Java\jdk-9.0.4 and put %JAVA_HOME%\bin at the top of both system and user Path variables, Java V8 is the one that runs from the command line when I try to launch the sanitizer (or Java -version) so it fails.

I tried running refreshenv and uninstalling V8, and I can’t restart for a while because the crash also corrupted my Duplicati database which will take a few days to rebuild.

What else can I try to force Java 9 and get the sanitizer running?


#2

No sure what’s wrong with your Java installation, but you should always be able to usw the full program path:

   C:\Program Files\Java\JRE-x.y.z\bin\java.exe -jar sanitizer.jar ...

#3

Thanks, that is what I had tried before give or take a typo and it hadn’t worked, but I think that doing it in cmd instead of Powershell got it working and it has started running now.