File Lost/Dissappeared Using Version 1.5.1

Has anyone else expressed concerns regarding files disappearing using the new version 1.5.1? I’ve been using Cryptomator for years and never actually lost a file. Today I tried to open a file and it said file not found, or something to that extent, then the file disappeared. The folder then synced to all devices before I could stop it. Thankfully, I had a 2 week old outdated copy in a trash folder on my phone to replace it. I am very concerned since nothing like this has ever happened before. I have noticed that Dokany seems to have introduced some bugs since my mount point/folder now occasionally randomly closes, but this has never actually caused files to permanently disappear. I see no glaring issue in the log file but I have now initiated debug mode to hopefully capture what is going on. I use Goodsync and Google Drive to keep synced copies on my android phone and windows PCs which has been a bulletproof very secure solution to date. My files and vault are just very small non taxing .xlsx and .docx files. The file that was lost was an 18kb .docx file. Any thoughts?

This sounds to me more like a synchronisation problem.

With version 1.5.0 we changed the vault format, therefore your vault needed to be migrated. Did you encountered any errors during migration? And did such an error happen again.

To also address the dokan issue: Does this also happen with the latest dokany version? Another change with Cryptomator 1.5.0 was the integrated dokany update check routine, therefore at least version 1.3.x should be installed.

And last, but not least: Be aware that you leak meta data if you are enabling debug mode because clear text paths are written to your logs file.

No, I never encountered any migration issues.
No, it hasn’t happened again.
I don’t know yet if the newest Dokany version causes issues or not. It hasn’t yet.
Thanks for the meta data note. When you say leaked you are only referring to the one PC that I have debug turned on and only the log files themselves correct? The meta data isn’t being leaked from my vaults themselves are they? Sorry if this is a stupid question.
I will update with any further issues.

He means that the log file on your computer where you have enabled debug mode will show the complete path to your files (unencrypted). So be careful if you want to make this log available to others.

I have the same problems.
the problem occurs since the tresor migration.
before this upgrade everything worked properly for me

I use typora markdown editor.
when I try to insert a image from clipboard now I get an i/o error

when I wrote new files and closed the tresor it didn’t save every file
after reopening the tresor, when I click on a file, the content of another one in the same directory is shown (file got duplicated, when i change it, only this one file changes)

outside the container it works fine.
I didn’t try to create a blank new one yet if the problem still occurs there

Well, this is very very bad. This new version of Cryptomator/Dokany is now completely unreliable/unusable. I have now lost a second file and numerous crucial updates. What is going on with this new version? I am using the same hardware/software configuration I have used for years. The only thing that is different is the new/improved versions of Cryptomator and Dokany. Tonight I updated the file, saved it, locked the vault, quit Cryptomator. Then a couple hours later I went to update it again and I got the same error/window I got before that said it was unable to open the file. When I looked again in the folder the file was gone. Just like before the file had just disappeared. Why would the file be there and then suddenly disappear after I try to open it??? That is the exact same thing that happened before. Something very screwy is going on because when I checked my phone the file had also disappeared, but it had not synced with my windows PC since my file update 2 hours earlier. I was very closely monitoring what Goodsync was doing. This new version of Cryptomator/Dokany is randomly discarding/deleting my files. I have used Goodsync for years and it has never caused a file loss. It is the most reliable sync software that is available. Also, I am thoroughly familiar with all of its intricacies and pretty much monitor all of its operations on a daily basis. I have been using Cryptomator since version 1.3.1, and I have never had any issues even remotely similar to this before. What is going on?

@AJ7 That sounds indeed more than annoying.

Can you send us a log file where the error appeared? Cryptomator stores logs for the 10 most recent starts of the application. If you don’t know the exact time, just zip the logs and send them to us.