Feature Request - Block cryptomator from attempting to open vaults created by future versions

For easing user support and migration in Future versions and vault formats, cryptomator should block opening masterkeys with a vault format Greater than the current supported version, and return a warning to the user their version is unsupported.

Example:
Cryptomator 1.5.x versions should implement a check that the vault is not greater than 7. This could help in the future If/when vault format 8 is released to stop “downgrading” related issues.

Reasoning:

I’ve noticed a few discussions/ help requests here and on github over the months, which have been caused or impacted by people “downgrading” cryptomator, or upgrading one machine and vault format, then attempting to connect from another machine which hasn’t been updated.

© 2020 Skymatic GmbH • Privacy PolicyImpressum