Disappeared Folders/Files - iOS / macOS

Hello,

i need help with Cryptomator. Today, suddenly all my Folders and Files are disappeared.
Till now, i ran Sunitizer and some help would be great.

I did not use Cryptomator for about 2 weeks, wanted to use on Mac, but updated Cryptomator on new Version, till then i cannot see my files.

My Devices: Mac Mini with macOS Sierra 10.14.5 /iPhone XS with iOS 12/13 (iOS 13 does not work with Cryptomator App)

Sunitizer Stats:

Some help would be nice. Thanks

Uploaded XXXXXXX.check.txt and
XXXXX.structure.txt

By the way, I recognized that Cryptomator created a second masterkey in the Folder,
now i have 2 masterkeys in Cryptomator Folder on iCloud. Anyhow Cryptomator renamed
the newer masterkey as masterkey.cryptomator and the older 1 as masterkey2.cryptormator

Do you remember which version you’ve used before? Maybe there’s still an old log file which are located at ~/Library/Logs/Cryptomator. What’s up with the multiple masterkey files? Please make a backup of them and try to switch them (rename masterkey2.cryptomator to masterkey.cryptomator and vice versa).

Tried to rename masterkeys, but still empty folder.

I used CM 1.3.2 on Mac, mostly used iOS App. Some day i wanted to use CM on Mac, got an Update Message and upgraded to 1.4, anyhow since then CM does not show me my folders.

Okay, i just recognized something. Wanted to locate to the path u wrote, and found iCloud Archiv and within another CM File was in. I unlocked it and got my Files back.

Sorry, have no time atm, gotta go to work.
I will look tonight in the path u wrote. I hope i can get the last some files, that is in the vault.

Thanks to iCloud Archive, i was able to unlock Vault normally, and 90% of my Files could be restored.

Anyhow in that iCloud Archive, CM had only 1 File and 1 Folder; the d folder and the masterkey. No key backup or something else, only these 2 things. In my normal CM folder, i have 2 folders, Masterkey and MK Backup.

Hi Tobi,
there are no old logs in Library.
(Maybe because i removed CM once and did a fresh installation to the latest
Version)

Have you checked the “correct” Library? It’s inside your home/users directory.

Upgrading from 1.3 to 1.4 shouldn’t have been a problem. The vault format hasn’t changed and is compatible with both versions. You can still download 1.3.2 here: https://cryptomator.org/downloads/#allVersions

Yea, I did. No old Logs.