Crytomator 1.5.12 keystore

Ubuntu 20.04, I’ve been using 1.5.8 without problem. Start app, click on vault, enter password (from a password app) and it unlocks. The “Save password” option when unlocking the vault is off. I have never used this option.

Upgraded to 1.5.12

General preferences shows an option: Store passwords with “KDE Wallet”. There is no other option.

Now when I click on a vault, I get

Please enter the passphrase to unlock OpenPGP secret key: xxxxxxxxxx

The displayed is one that I use for communications.

The dialog is system modal which stops access to a password app. Mouse doesn’t work. I can hit the Esc key and the dialog disappears. An error message appears:

Error attempting to open the wallet kdewallet. The wallet was encrypted using the GPG key ID but this key was not found on your system.

Click the vault again, same thing happens. But on this second time after Esc to cancel it, the old password dialog appears, and I can enter the password to unlock the vault. The “Save password” option is still off.

I have tried removing Cryptomator, and all its settings in ~/.config/Cryptomator and reinstalling, and re-adding the vaults without success.

The first time starting after this, Preferences/General shows “Store passwords with Gnome keyring”. If I click the drop down it shows KDE Wallet. Neither options matter for the behavior.

If I use Version 1.5.8, I can continue with the older behavior.

How do I get rid of the annoying unlock keychain dialog and revert to the old behavior from 1.5.8 ?

© 2021 Skymatic GmbH • Privacy PolicyImpressum