Cryptomator not mounting vault on Kubunt 17.04

Dear community,

I freshly installed cryptomator on a couple days old reinstallation of Kubuntu 17.04 on my Lenovo X1 Carbon. Everything is brandnew so far. Yet I cannot mount a vault I was able to create successfully, when I chose to access the vault using Dolphin (I click on the 476.5 GiB encrypted hard drive"I get the error
"Beim Zugriff auf „476,5 GiB verschlüsseltes Laufwerk“ ist ein Fehler aufgetreten, die Meldung lautet: Ein nicht genauer angegebener Fehler ist aufgetreten: No such interface ‘org.freedesktop.UDisks2.Filesystem’ on object at path /org/freedesktop/UDisks2/block_devices/dm_2d0"

English translation: “The attempt to access “476.5 GiB encrypted hard drive” prompted an erro, the message reads: An unspecified error occured: …”.

I have tried reinstalling Cryptomator a couple of times.

Hope you have an idea,


That doesn’t seem right. How should dolphin know the drive is encrypted. I am pretty sure that the drive you are trying to access is not the Cryptomator vault. Dolphin should open as soon as you unlock the vault from within Cryptomator pointing to the location of the vault. If that does not happen you could have a look in the logfile for any errors.

You could also try mounting the vault by hand by copying the WebDAV url from within the Cryptomator UI after unlocking.

Thanks a lot for your quick response. As a matter of fact, no log file is being created (looked in ~/.Cryptomator/cryptomator.log , so I can’t give you any more info than the one I have. Dolphin is not prompted upon opening the vault either .Clicking “Show hard drive” in the main window of Cryptomator has no effect. So far I can create, delete, lock and unlock vaults, but I cannot access them.

So my current WebDAV-Adress being: http://localhost:xxx/yyyy/Tresor I entered “webdavs://localhost:xxx/yyyy/Tresor”. is that how I am supposed to do it?

Other than that I tried

mount http://localhost:xxxx/yyyy/Tresor
mount: http://localhost:xxxx/yyyy/Tresor: Datei oder Verzeichnis nicht gefunden```

So the drive could not be found. Please take note that davfs2 is installed on my system.

It might be dav:// or webdav:// but most likely not webdavs:// as the “s” suffix normaliy denotes the use of TLS, which required creation of a certificate for localhost. The only option would be to create self-signed certificates, which the file explorer wouldn’t accept.

Thank you for your answer. In Dolphin, I now entered:

“webdav://localhost/xxx/yyyy/Tresor”. I cannot directly create files within there, but I can create folders and insert files. This would be a solid work-around for me. Thanks a lot for your help.