Cryptomator in raspi 4 - gdrive

Hi all, and thanx for all the helpful info you post.
I have a cryptomator vault created in a windows 10 machine, that syncs with Google drive.

I wish I could see the file in gdrive, unencrypted.
I mounted G drive with rclone, and then tried to use the new CLI, that worked ok. Mounted another folder for the vault with davfs2, but i cannot do anything.

Has anyone got a clue on how to do this?

I do not have a local vault in the pi. Just want to access the encrypted files in the cloud.

Just like in the android app

Thanks to all

Pablo

Welcome to the Cryptomator Community :slight_smile:

When using davfs2 I recommend placing an entry in fstab, otherwise you can only mount it as root and need to fiddle around the root owner ship and rights all the time. (Note that in fstab you can’t use certain characters directly but need to enter a code, e.g. spaces are replaced by \040. Additionally, some provider need certain parameters set in davfs2.conf.

I can’t say more, since I don’t use GoogleDrive and especially not in combination with WebDAV.

HI, tnx for your reply.
Im really new in all this.
I only need to view the encrypted files. Just like the android app.
Perhaps you can tell me another way, perhaps Im going the wrong direction…using rclone, etc…

Thanx

Pablo

I use rclone with cryptomator-cli, but with a webdav provider, not gdrive.

Here is some hints that might help, with examples you could adapt for your folder and rclone names.

  1. mount rclone with write caching. I’d recommend against using full as it will download a lot of data when browsing directories.

rclone mount Gdrive: /home/pi/gdrive --vfs-cache-mode writes

  1. As @infeo has mentioned, permissions can be an issue when mounting as root. I use mount options to work around this. Also try port 8081, I think there’s something already using port8080 in raspbian
 java -jar cryptomator-cli-0.4.0.jar --bind localhost --port 8081 --vault gdrivevault=/home/pi/gdrive/CRYPTOMATOR_VAULTNAME
 
 sudo mount -t davfs http://localhost:8081/gdrivevault /home/pi/gdrivevault -o user,rw,uid=$(id -u),gid=$(id -g)

Please ensure you have backups of your data, especially if adding items to the vault this way. To my knowledge there hasn’t been much testing with cryptomator on rclone vfs mounts, especially with CLI

1 Like

Thanx. I will try and and ocme back.

Thanx! It worked perfectly!!!

Regards

Pablo

© 2020 Skymatic GmbH • Privacy PolicyImpressum