Copying a Cryptomator vault with Filezilla: "file already exists"

I installed Cryptomator on Windows, then on Android. Just want to transfer a 4 GB vault using Filezilla and a ftp server on my phone.
All the files have been transfered and I can open the vault on my phone. I can see the files but there is an error message when I try to open a file so I cannot open any.
Par of the explanation: at a moment, during the transfer, filezilla shows the message “the file already exist, do you want to replace, rename, ignore…”.
I suppose it is impossible that two encrypted files in cryptomator do have the same name ! So when I choosed “replace”, I was nearly sure the vault would not work on the phone !
I suppose the error deals with something wrong in Filezilla: encrypted file name to long ?
I tried with another vault and it there was the same issue.
Thanks for any advice !

This will not solve your problem, but why do you want to transfer a vault to the android device?
Why not using cryptomator in the way it supposed to be? Upload the vault to a storage provider like google, Dropbox etc and access the vault directly from android. No need to store the encrypted files on the device.

Thanks for your reply, I am not very fond of clouds, and what I like in Cryptomator is that we can use local storage, in Windows and Android. So I use sometimes Veracrypt (Windows and Linux but not Android), Eds lite (android), SSE file encryptor (Windows and Android).They don’t have a cloud connect option.
Cryptomator exists for Windows, Android and Linux, that suits me very well and I am trying it for this reason.
Coming to Filezilla, I must try unchecking some options in it, that are something like “treat files without extension as ASCII”. But it needs about half an hour to try it with my 4 GB file !

Here we are ! I tried with a 500 MB vault, in three different ways and it works.
I had to do the following:

  • in Filezilla options, uncheck the two cases “treat files without extension as ASCII” and “treat files beginning by a dot as ASCII”
    (Filezilla menu “transfers”, “file types”
  • When Filezilla asks “file already exists”, choose “ignore”.
    The transfer is rather long but once a vault is created (in Windows or in Android), opening a vault is very fast !
    I really enjoy this soft.

(Edited) The transfer works well now but I can’t understand how Filezilla may find the same files (generally two, but differents at each vault transfer) already presents when it is tranfering the encrypted vault: before each try, I removed the vault within Cryptomator from the phone, then deleted the vault and all its files with my android file explorer. This seems to be an issue of Filezilla.