Can't close to tray

The manual says “As long as the vaults are unlocked, the Cryptomator window can be closed without quitting the application. Cryptomator will be minimized to the tray icon. By right clicking the tray icon, you can open or quit Cryptomator.”

But I can’t. If I close the window, the program exits, and I think I can loose data.

Why can’t I close to tray icon?

Hi. Did you look in the Task Manager if the cryptomator process is still running?
Do you have error messages in you logfile?
Do you use 3rd party apps to manage your system tray (like TrayIt or something like that)?
Maybe there is just an issue with displaying the cryptomator symbol in the tray.

Actually there is no function or configuration in cryptomator for this, so the cryptomator window should always close without quitting.

There is no cryptomator task running, nothing in log, nothing at all. Program simply closes, and vaults lock /if you run cryptomator again you have to unlock them). No message saying “are you sure to close?”, nothing. Thanks.

This should actually work and I just tried it again on both macOS and Windows:

  1. Open Cryptomator
  2. Unlock vault
  3. Close Cryptomator (by pressing red button at the top-left on macOS or X button at the top-right on Windows)

Cryptomator is still running after that and I can keep working with the vault’s drive.

However, I remember that someone made a comment in an unrelated issue that it didn’t work but he couldn’t reproduce it:

I’m not absolutely sure if that could be a bug. But without a reproducible case, it’s almost impossible for us to debug the issue.

On Linux, the app does exit without asking when closing the window. I have tried under Fedora 27 with the TopIcons Plus Gnome extension that allows for tray icons in the top bar, since Gnome 3.26 got rid of tray icons.