Automatischer Foto-Upload

Das sollte kein Problem sein, nur der physikalische Speicher des Handys und der der Cloud sollten da eine Einschräkung darstellen. Werden wir untersuchen danke für den Hinweis!

So, erste Tests sind durch, hier die Ergebnisse:

  • 500 Fotos erstellt, alle wurden hochgeladen ohne Abstürze etc.
  • Fotos werden erfasst wenn
    • Tresor entsperrt
    • Tresor entsperrt und Upload aktiv
  • Serienfotos erstellt, 3 pro 2 Sekunden (schneller konnte meine Kamera keine Bilder machen) 500 Stück wurden alle 500 erfasst und ohne Fehler hochgeladen

Gibt es vielleicht weitere Details die zu Fehlern hätten führen können?

Danke fürs Testen!

Ich habe ebenfalls kurz getestet:

  • Korrekt, so auch bei mir. Fotos, die ich bei entsperrtem Tresor aufnehme, werden erfasst, und beim nächsten Sperren und Entsperren des Tresors hochgeladen
  • nett wäre es, wenn der Upload direkt startet, aber in der Praxis eher selten, dass man Fotos macht während der Tresor entsperrt ist
  • ich habe mehrfach Serienbilder mit dem Samsung Galaxy S9 duos aufgenommen (schätze ca. 17 bis 20 pro Sek), es werden jeweils aus der Serie nur 2 Fotos hochgeladen, jeweils das Letzte und ein anderes von weiter vorn aus der Serie.
  • ich teste es später noch mit einem anderen Handy
  • Die Frage nach der Anzahl galt der Funktion “Dateien hinzufügen/hochladen”, also manuelles Hinzufügen von Fotos/Dateien zum Tresor.
  • Hier sperrt sich mein Tresor, wenn ich alle meine Bilder auswähle und hinzufügen will, ca. 3.000

Können Sie mir eine App empfehlen, die so viele Bilder hinbekommt? Dann teste ich das bei mir auch.

Alles klar, schauen wir an, danke für das Feedback.

So, ich hab jetzt die neue Beta-Version installiert.
Allerdings scheint der Photo-Upload noch nicht zu funktionieren.
Aktiviert sind:
-Upload
-nur mit WLAN
der Tresor für den Upload ist auch ausgewählt und gespeichert.

Ich hab den Tresor gesperrt, entsperrt und dann Fotos gemacht -> kein Upload.
Gibt es ein Vorgehen, das einhalten muß?

Danke für die Rückmeldung.

Nein, eigentlich sollte das so passen :+1:.

Wäre super ein Log-File zu haben um das Problem weiter eingrenzen zu können.
Da dank Android für die Version 7.x und davor, eine völlig andere Implementierung dieser Funktionalität notwendig war, könnte sich darin ggfs. ein Fehler befinden, der uns noch nicht übermittelt wurde.

Soll ich das log direkt hier rein posten? Dann wird es aufgrund der Länge echt unübersichtlich…
Oder direkt an den Support senden?

Auch aus Datenschutzgründen lieber direkt an die Support-Mailadresse oder per direkter Nachricht (und zB Firefox send) an mich. Danke :slight_smile:

Vielen Dank für das Log-File :tada: .
Wir konnten das Problem finden (betroffen sind Geräte mit Android version kleiner 7.x) , lösen und werden in den kommenden Tagen in der Version 1.4.3-rc1 die Änderung als Beta zum testen veröffentlichen.

1 Like

Can agree with Pat; sliders are working now, auto upload not so much. Will reply when next rc comes along.

Ich habe noch Vorschläge für den Photo-Upload:

  1. Mir würde es helfen, wenn die Unter-Ordner der Fotos im Quell- ins Ziel-Verzeichnis übernommen werden, d.h. WhatsApp Fotos sind dann in ihrem Ordner, Messenger Fotos in ihrem etc.
  2. Hilfreich fände ich, wenn die Fotos nach erfolgreichem Upload NICHT erneut hochgelanden werden, z.B. wenn sie im Ziel gelöscht werden. (das lässt sich evtl. über eine Status-Änderung am Foto realisieren von hochzuladen auf erfolgreich hochgeladen)
  3. auch hilfreich fände ich, wenn alle Fotos, die bereits auf dem Handy vorhanden sind, mit einer Abfrage auch zum Hochladen markiert werden. Also dass ich als Nutzer die Möglichkeit habe, alle bereits vorhandenen Fotos hochladen zu lassen (möglichst in ihre Ordner, siehe 1.) (Kritisch ist hier die Masse, wenn es mehr als 1.000 sind scheint es nicht zu gehen)

Merci!

@Pat and @zbe: We just published version 1.4.3-rc1 which includes a fix for the auto photo upload on pre 7.x devices. Join our beta test.

1 Like

Danke für das Feedback :smile:!
Zu:

  1. Die Bilder weiterhin auch im Tresor in den Unterordnern zu speichern ist tatsächlich eine gute Idee. Habe ein Issue dafür auf Github angelegt, das hat aber nicht die höchte Priorität.
  2. Sollte so nicht sein, konnte ich aber auch bei manchen Apps (zB Threema) beobachten. Der Auto-Photo-Upload funktioniert nämlich so, dass wir an das System mitteilen, dass wir benachrichtigt werden möchten, vereinfacht gesagt wenn Bilder abgelegt wurden. Manche Apps wie Threema beim öffnen deren Galerie triggern diese Bilde auf irgend eine komische Art und Weise, sodass uns das Betriebssystem sagt, dass das Bild neu wäre. Deswegen haben wir es dann unter Umständen erneut in der Liste obwohl es schon hochgeladen wurde. Löschen wollen wir es aus der Liste aber auch nicht einfach, da es ja theoretisch ein anderes mit dem gleichen Namen sein könnte. Wir sind an dem Thema dran, haben aber bisher noch keine bessere Lösung gefunden als auf nummer Sicher zu gehen und diese Datei in der Liste zu lassen. Wir bleiben da aber dran!
  3. Geht so nicht direkt, das liegt vor allem an Punkt 2. hier, dass wir eben nicht diese Benachrichtigungen bekommen aber händisch könnte man das schon irgendwie hinbekommen aber das wird dann vermutlich ziemlich aufwändig aber schreiben wir uns auf jeden Fall auf und schauen uns bei Gelegenheit an.
    Den Upload von 2k-Dateien bekomme ich tatsächlich auch nicht hin, ein kurzes Debuggen gab bisher allerdings noch keine Rückschlüsse, wir schauen uns das an.
1 Like

Quick test shows it’s working.
Don’t know if its intended to work like this but if you take photos while vault is unlocked you have to perform lock/unlock for new upload to begin.
Also, it only uploads photos, not videos.

Thanks for all the work.

1 Like

Ich kann nach wie vor den automatischen Upload nicht starten. Zugriff auf den Speicher wurde erlaubt, dennoch lädt Cryptomator auf meinem Android 9 keine Fotos hoch - ob der Tresor jetzt offen oder geschlossen ist, ich mich im WLAN befinde oder nicht oder sonst was. Könnt ihr mir helfen?

Läuft eventuell parallel eine Firewall App?

Nein, keine Firewall, kein VPN. Alles im Normalzustand.

In diesem Fall wäre ein Log-File sehr hilfreich: How do I enable debug mode on Android?

Hallo zusammen,

Ich greife den Threads mal auf, da ich ähnliche Probleme erfahre. Installiert habe ich die Version 1.4.3 auf einem Pixel 2 mit Android 10, Sicherheitsupdates vom 5.12.2019.

  1. wenn ich 1.430 Photos manuell auswähle und hochlade, dann bricht der Upload bisweilen immer ab. Ich habe die automatische Sperrung der Tresore bereits deaktiviert. Ebenfalls habe ich die Display-Sperre auf das Maximum von 30 Minuten gesetzt. Dennoch habe ich durch mehrmaliges starten des Uploads erst 224 Fotos hochladen können.

  2. Das automatische Photo-Hochladen ist konfiguriert, funktioniert jedoch nicht. Der Zugriff auf den internen Speicher ist gesetzt. Zusätzlich habe ich versucht den am 29.7. beschriebenen Tipp den Default Storage auszuwählen versucht. Ich kann jedoch nur benutzerdefinierte Orte ergänzen. Der Standardwert ist gesetzt auf: storage/emulated/0. Ich habe den DCIM Ordner ausgewählt und hinzugefügt. Mal sehen ob das ausreicht. Ich werde berichten.

Grüße
snafu

Hey hey :slightly_smiling_face:,

zu

  1. : Wir haben die Grenze noch nicht genau herausgefunden und das Problem auch noch nicht gelöst aber 1000 Bilder auf einmal hochladen funktioniert, also bitte erst mal in 1000er “häppchen” unterteilen. Wir arbeiten gerade noch an anderen Baustellen aber sobald Kapazität frei ist werden wir uns diesem Bug widmen: https://github.com/cryptomator/cryptomator-android/issues/166
  2. : Wir haben in der 1.4.3 ein Problem unter Android 10 mit der Abfrage, ob eine WLAN-Verbindung besteht, es wäre ein Versuch wert, testweise in den Einstellungen “Upload only using WIFI” zu deaktivieren, dann sollte es funktionieren. Alternativ würde es auch durch Updaten auf die 1.5.0-beta2 funktionieren. Hier kann man mehr darüber lesen: https://github.com/cryptomator/cryptomator-android/issues/174#issuecomment-555015201