Always Ejecting drive Failed and Reveal Drive

Cryptomator 1.4.15, windows 10 1903, Dokany
Problem 1
Every time i try lock my vault i get this error “Ejecting drive failed”, i tried reinstall cryptomator, tried other versions nothing helped even tried on other windows computer/laptop and i get the same error every time.
Problem 2
“Reveal Drive” doesn’t work at all, when i click reveal drive it redirects in different folder every time(Documents, Downloads or Desktop) Vault its inside C:\Vault
Any idea how to fix ?

Regarding problem 1:

Is this error shown inside Cryptomator or is this a Windows error? What is your installed Dokany version? And if you get this error also on other machines, they all must have a certain configuration/software in common. Do you have any guesses?

Regarding problem 2:
Reveal Drive shows the access location of the content of your unlocked vault. (not the storage location of the encrypted files) So if you unlocked your vault successfully and have access to the decrypted content, “Reveal Drive” should open the windows explorer with showing this content.
If it is not working, can you try out on the terminal the following command?

explorer /root,"C:\Vault"

This command should open the Windows explorer showing the content of the directory C:\Vault