Access denied when trying to open PDFs with Adobe Acrobat

Probably the same incident as me Cryptomator corrupted my files
The user most probably been using the application for sometime.
I doubt it would always be write protected

Update : It was indeed write protected , but why ? How come that is happening ?

Just tested some things, it does not mattter how I try to open files. Both, explorer and open dialogue are leading to the reportet error. Files are not write protected.

Some further information:
-OS: Windows 10
-Interface: Dokany

Switching the interface to WebDAV solved the problem. This is a workauround I can accept but it does not solve the real porblem so I am still looking for further ideas.


I am experiencing exactly same issue from today suddenly.
I am using Windows 10
Cryptomato 1.4.6 (Dokany)
and I can open XLS file for instance but no PDF.
Thanks for your help

After re-reading the posts, I cahnged the mounting method to webdav and I can now open the PDF files.
Don’t know much about the difference btw Dokany vs WebDav. But I confirm when switching to dokany it’s not worling

Hi All,

I’m using 1.4.6 on a Windows 10 x64 machine too.

I see the same thing too. I never had this problem before but I recently installed and switched to using dokany vs WebDAV.

I thought dokany would be better (cleaner) but if I’m going to see issues like this, why would I use dokany?

I need this to be bulletproof.


Hi everybody,

Good to hear I’m not the only one affected.
Running Cryptomator v1.4.6 on a Win 10(E) x64 machine and only recently started to get problems.

First, I didn’t or doesn’t accept the correct password (on a Dropbox directory). Have to pause and reactivate Dropbox sync before Cryptomator opens the directory.

Then, PDFs cannot be opened (“Access denied” or “General failure” in Acrobat, “A device attached to the system is not functioning” in PDF X-Change Viewer). If I delete the same files, they disappear until I refresh the directory, where they appear again… Edge also doesn’t want to open the PDF.

Switch from Dokany to WebDAV didn’t help anything. Any suggestions?


@als If the files are not deletable, they are read-only. See here: Careful with files with read-only attribute

Can anybody create a debug log and send it to me via PM? It could be helpful since i can’t reproduce the issue and maybe the log file contains a hint.

Thanks, @infeo. That was in fact the case. No idea, though, how those files in the file system came to be “protected”. You find my debug log dump under

Cool that this is solved. Regarding the log-file, i meant getting an insight of the problem where the vault is not write protected but .pdf files not accessible.:wink:


I’m experiencing the access denied errors when opening PDFs from the encrypted drive, too.
Using Cryptomator 1.4.8 + Dokany on Windows 10 x64 Enterprise 1809 17763.437 (on Core i5 + SSD).
Most PDFs open without problems but some random PDFs give an access denied error when opening them in Adobe Reader DC 2019.010.20099.
Retrying these PDFs may result in some more errors until it finally works. So in the end every PDF opens successfully but there seem to be PDFs that are more error prone than others.

I had Cryptomator write a debug log, so I got an error and a following successfull opening of that same PDF in a log.

@infeo Obviously I can’t send you a PM but could eventually reply with the log attached if you send me a PM.


Very, very strange…

@Klaus_Salger i send you a message, just answer me.

I was experiencing the same issue when opening PDFs in Abode Reader, but the problem didn’t occur when opening the PDFs in Chrome.

I found the following article that shows you how to disable protected mode in Adobe Reader. I know this isn’t a fix, but it’s a workaround for those who don’t mind disabling protected mode.

1 Like

I have the same issue when opening PDFs in Acrobat Reader. I’m on Windows 10, Acrobat is at 2019.012.20034. I would very much appreciate if you could fix this issue as disabling Acrobat Protected Mode is not a good long term solution nowadays.

Thanks and Best Regards!

Same problem here :frowning:

Unfortunately, I have the same problem (Windows 10, Acrobat Reader DC, Dokany). The behavior is somewhat erratic. Sometimes a file opens just fine, sometimes it does not. Deactivating the Adobe Reader Sandbox does not seem like a viable option to me, considering the regular security issues in Acrobat Reader.

I get this on Windows 10; Cryptomator 1.4.10 Dokany. Isn’t consistent at all. I’ll try to open a file and it won’t work 2-3 times and then it works on the same file when I try again. I’ve only seen this with Adobe Reader. Same file with another PDF viewer works fine every time.

Same problem here on Win10 x64, Cryptomator 1.4.11%2B114-x64.

I created an issue on the bug tracker:

Unfortunatly we cannot fix this in Cryptomator because this bug also occurs when one uses “plain” Dokany. Thus this might take a while.

Hallo, ich habe dasselbe Problem und kann mit dem Workaround gut leben, wenn sichergestellt ist, dass die Dateien dadurch weder beschädigt, noch verändert werden. Ist das vorhanden. Kann mir jemand zum Issue noch mehr Informationen geben?

I hope dokany will fix this soon…