1.5.4 (exe166) org.cryptomator.cryptofs.migration.v7.InvalidOldFilenameException when migrating

Running 1.4.x before on Win10. Deinstalled dokany, full new install of 1.5.4.
After installation, trying to migrate, but I get this error:

org.cryptomator.cryptofs.migration.v7.InvalidOldFilenameException: Can't base32-decode '6WONUQ==' in file C:\Users\Heiko\one-drive-full-domainname\subfolder\d\FY\327T67G2FLRNH4XWMZF4BSAPBAZEQO\06WONUQ==
	at org.cryptomator.cryptofs.migration.v7.FilePathMigration.getDecodedCiphertext(FilePathMigration.java:223)
	at org.cryptomator.cryptofs.migration.v7.FilePathMigration.getNewInflatedName(FilePathMigration.java:209)
	at org.cryptomator.cryptofs.migration.v7.FilePathMigration.migrate(FilePathMigration.java:122)
	at org.cryptomator.cryptofs.migration.v7.MigratingVisitor.postVisitDirectory(MigratingVisitor.java:55)
	at org.cryptomator.cryptofs.migration.v7.MigratingVisitor.postVisitDirectory(MigratingVisitor.java:17)
	at java.base/java.nio.file.Files.walkFileTree(Unknown Source)
	at org.cryptomator.cryptofs.migration.v7.Version7Migrator.migrateFileNames(Version7Migrator.java:119)
	at org.cryptomator.cryptofs.migration.v7.Version7Migrator.migrate(Version7Migrator.java:101)
	at org.cryptomator.cryptofs.migration.Migrators.migrate(Migrators.java:112)
	at org.cryptomator.ui.migration.MigrationRunController.lambda$migrate$2(MigrationRunController.java:115)
	at org.cryptomator.ui.common.Tasks$TaskImpl.call(Tasks.java:139)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException: com.google.common.io.BaseEncoding$DecodingException: Invalid input length 6
	at com.google.common.io.BaseEncoding.decode(BaseEncoding.java:219)
	at org.cryptomator.cryptofs.migration.v7.FilePathMigration.getDecodedCiphertext(FilePathMigration.java:221)
	... 17 more
Caused by: com.google.common.io.BaseEncoding$DecodingException: Invalid input length 6
	at com.google.common.io.BaseEncoding$StandardBaseEncoding.decodeTo(BaseEncoding.java:710)
	at com.google.common.io.BaseEncoding.decodeChecked(BaseEncoding.java:233)
	at com.google.common.io.BaseEncoding.decode(BaseEncoding.java:217)
	... 18 more

I started reading about path length issues, but it seems I am even one step before “some files are lost” problems because migration process does not finish.

Any suggestions how to deal with it?
Additionally, I suppose that my oneDrive folder structure will be problematic because “root path” to \d is 77 chars (**C:\Users\Heiko\OneDrive - full path with domain\subfolder**d).

Thank you for your help!


Welcome to the Cryptomator Community :slight_smile:

This is here not the issue. Cryptomator can deal with long paths as long as the filesystems mocks about it. The internal path length of a vault is at most 268 characters, OneDrive has a limit of 400 characters and i think the limit is counted from the OneDrive root (!= file system root).

Well, yeah, kinda. Do you have a backup of your vault or a file history where you can see when this file appeared?

The encrypted file C:\Users\Heiko\one-drive-full-domainname\subfolder\d\FY\327T67G2FLRNH4XWMZF4BSAPBAZEQO\06WONUQ== has a too short name. Even cleartext files with a name only one character long have encrypted file name length of ~33 chars. This means the file got corrupted.

Interestingly, on another PC (also win10), the update to 1.5.4 an migration of succeeded without problems - using the same vault on oneDrive. And works now without issues.
I will try to look through some backups.
Thank you for your help!

Strange, indeed.

Maybe a synchronisation issue or do you use FilesOnDemand? Of course our migrator could have done also something wrong…

So, what is your suggestion? Complete uninstall?
For the update, I just deinstalled dokany and started the installer.

Without any further actions, the problem is gone now.

I guess something like this happened:
I migrated the vault from pc1, this was effortless. As far as I can see, all (?) file names have changed during this procedure.
On pc2, migration stucked because of invalid file names. After posting my issue here, I noticed that OneDrive client was still busy syncing the vault and renaming lots of files (s. screenshot).
Now, syncing is finished and the migration problem vanished :smile:

Thank you for your help!

Glad that the problem is solved now. :slight_smile:

So I guess this is another problem falling into the category “incomplete sync”.